1

I tried to compile and install manually a new version of compat wireless on my ubuntu 12.10, because i had a bit wifi problems. The problems aren't gone but now my internal wifi card (atheros ar9485) doesen't show (tried modprobe ath9k, no success), and i want to get back to like things was before. Used checkinstall and have tried dpkg -r compat-wireless but when i reeboot after the uninstall then i get no visible wifi connections (i have an usb dongle which uses rt2800 driver too which doesent show).

2
  • 1
    How exactly did you install it? Can you edit your answer to provided the specific, full commands? (You said you used checkinstall but can you provide more details please?) Jan 11, 2013 at 23:53
  • After unpacking the bz2 i did this: ./scripts/driver-select rt2800 make sudo checkinstall Clicked enter through the checkinstall except the last one where it said "yes could be a good idea". Was something about exclude something. Jan 11, 2013 at 23:57

1 Answer 1

0

This problem sometimes happens because installing the new package replaces an old (or otherwise different) version, and uninstalling the new one leaves you without either.

Perhaps a previous version of compat-wireless was installed before you installed with checkinstall. If so, you should reinstall that. You can check whether or not this was the case by looking at /var/log/dpkg.log.

4
  • I did an apt-get upgrade so it has no entrie before that. I haven't installed any network related software, so what do ubuntu 12.10 uses as default? Jan 12, 2013 at 0:26
  • @user1937237 Running apt-get upgrade doesn't reset dpkg.log. You can look farther back in the files whose names start with dpkg.log followed by a number, but it is probably not necessary--you wouldn't be looking for an entry documenting the older version's installation, but rather its removal. (Ubuntu 12.10 does not have any package called compat-wireless, though, so if you used an official Ubuntu ISO to install and didn't customize the system or install software from your computer's manufacturer, it's unlikely installing compat-wireless with checkinstall replaced it.) Jan 12, 2013 at 0:29
  • I may add i used --purge on the removal first time. Maybe it has some impact. Jan 12, 2013 at 0:50
  • @user1937237 --purge doesn't affect what is logged. It just causes systemwide configuration files belonging to packages being removed, to be removed too. Feel free to post your log file(s) at paste.ubuntu.com and update your question with a link, if you wish. Jan 12, 2013 at 0:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .