I have an Asus S1-AT5NM10E HTPC which has an integrated IR receiver. On Ubuntu 12.04, I have installed XBMC, but when I press "OK", "Vol +/-" or "Back" on my MCE remote (in fact, a Logitech Harmony 300i configured to emulate an MCE remote), XBMC doesn't seem to detect the signals. However, arrow buttons do work well.

I know that the faulty buttons are detected by the computer because, when I run cat /dev/lirc0, a bunch of weird characters are displayed each time I press one of them. The IR receiver is also able to detect a completely different remote (TV) because another family of characters were displayed.

I have installed lirc (sudo apt-get install lirc) to see the output of irw. Unfortunately, irw didn't output anything.

Thanks to ir-keytable, I could determinate the integrated IR receiver is from Nuvoton:

$ ir-keytable 
Found /sys/class/rc/rc0/ (/dev/input/event4) with:
        Driver nuvoton-cir, table rc-rc6-mce
        Supported protocols: NEC RC-5 RC-6 JVC SONY LIRC other 
        Enabled protocols: LIRC 
        Extra capabilities: <access denied>

Why are some buttons not working? How can I make them work?


It seems it is a problem of mapping, or something.

Just run sudo dpkg-reconfigure lirc, and in the first screen (Remote control configuration:), select Windows Media Center Transceivers/Remotes (all).
In the second screen (IR transmitter, if present:), you can select None.

Now, irw can output text:

$ sudo irw
000000037ff07be1 00 KEY_UP mceusb
000000037ff07be1 01 KEY_UP mceusb
000000037ff07bdf 00 KEY_LEFT mceusb
000000037ff07bdf 01 KEY_LEFT mceusb
000000037ff07bde 00 KEY_RIGHT mceusb
000000037ff07bde 01 KEY_RIGHT mceusb
000000037ff07be0 00 KEY_DOWN mceusb
000000037ff07be0 01 KEY_DOWN mceusb
000000037ff07bdd 00 KEY_OK mceusb
000000037ff07bdd 01 KEY_OK mceusb
000000037ff07bdc 00 KEY_BACK mceusb
000000037ff07bdc 01 KEY_BACK mceusb

And, every buttons in XBMC are detected.

  • Thanks. It seems like much of ir-related stuff was moved into the kernel, and lirc used to complicate things. But, I just tried with a clean 14.04.01 and this answer works. Make sure you restart xbmc/kodi after installing lirc. Nov 1 '14 at 22:12
  • also, if you have not got lirc installed, and a simple apt-get install lirc solved this for me. thanks
    – Sverre
    Jan 10 '15 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.