Possible Duplicate:
How can I fix a 404 Error using a PPA?

So I am getting this error when I try to run the system updater:

Failed to download repository information
Check you internet connection

W:Failed to fetch https://installer.id.ee/media/ubuntu/dists/quantal/main/binary-  
  amd64/Packages  The requested URL returned error: 404 Not Found
W:Failed to fetch https://installer.id.ee/media/ubuntu/dists/quantal/main/binary-  
  i386/Packages  The requested URL returned error: 404 Not Found
E:Some index files failed to download. They have been ignored, or old ones used instead.

I have done:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

I also changed the server from where Ubuntu tries to fetch them and after all this the problem still persists.

I notice that the problem is caused by intaller.id.ee I tried to install ID-card software from there but it failed to download it and the trace was still left onto my computer. I did wget to the address they use. I think if I would remove that URL from the listing the problem would be solved but I have no idea how to do that as I am not familiar with all the commands yet.

So what do you guys think? Might that be the problem? If so then how do I go with it?

marked as duplicate by fabricator4, qbi, Ringtail, Thomas Ward, Eric Carvalho Jan 12 '13 at 2:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


The link is probably defunct or has been moved, so it won't work.

To "fix" this issue, you can just remove it from your software sources. To open your software sources, there are a variety of methods:

Method 1:

  1. In the Software Updater, click on "Settings" in the bottom-left corner

Method 2:

  1. Open your system settings
  2. Click on "Software Sources"

Method 3:

  1. Open the Ubuntu Software Center
  2. Click on "Edit" in the top-left
  3. Click "Software Sources" at the bottom of the drop-down

Once you've opened the Software Sources:

  1. Click on the "Other Software tab".
  2. Find that link, https://installer.id.ee/media/ubuntu/dists/quantal/main/binary-i386/Packages, in the list of software sources.
  3. Delete it, and any other versions of that same link.

After that, you should be able to update without getting that error!

  • It worked :) Thanks for the quick and useful reply! – Kaspar Jan 11 '13 at 22:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.