1

I have an older computer that I got from work when we upgraded to newer ones. I don't know the brand, it's kind of a mix and matched machine, but I can get some better info if necessary.

Anyway, I try to shut it down properly from the shut down button in what I call the "start" menu in the upper right hand corner of the screen. However, it just goes to the purple screen with the word "Ubuntu" with the 5 red/white dots below it, and stays there all night.

The only way to shut it down is to unplug it or turn off the switch on the power supply.

Is this a Ubuntu issue or something in the BIOS? I'm running 12.04.1. The processor is an AMD Sempron 2600+

It had Windows XP on it previously, and I don't think it had this problem with Windows, but I'm not certain because I installed Ubuntu on it almost as soon as I got it.

Any help is appreciated. Thanks!

1

I am running Ubuntu 13.10 on my Surface Pro (with touch cover) and I am facing the same problem (which I fixed!)

the shutdown -h now command works after a while, it gets stuck there for 2 or more minutes, my guess is that it forces the shutdown/reboot, which is not good.

The problem is that network-manager does not quit when the signal for KILL is passed to it. You have to stop it before rebooting/shutting down:

I have created a bash script called K99_stopnm on /etc/init.d sym linked under /etc/rc0.d/ and /etc/rc6.d/ as K99_stopnm_sm and it works great, if you press the down arrow when you get the ubuntu splash screen on either reboot or shutdown, you will see this:

shutting down network manager

network-manager stop/waiting
network manager is down

my script looks like this:

#!/bin/bash

echo "shutting down network manager";

stop network-manager;

echo "network manager is down";

sleep 2;

hope this helps and I hope the Ubuntu team can fix this anytime soon

thanks

0

I'm not aware of the cause of your problem, But i have a simple solution. Open Terminal and try this command and see if it powers off.

sudo shutdown -h now

Let me know whether it worked. Hope it helps :)

0

Okay, it does not shut down. Here's exactly what it says:

modem-manager[653]: <info> Caught signal 15, shutting down...                        [OK]
*All processes ended within 1 seconds....                                            [OK]
nm-dispatcher.action: Caught signal 15, shutting down...
nm-dispatcher.action: Could not get the system bus. Make sure the message bus daemon is running! Message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the  reply timeout expired, or the network connection was broken.
 *Deconfiguring network interfaces...                                                [OK]
 *Deactivating swap...                                                               [OK]
 *Stopping remaining crypto disks...                                                 [OK]
 *Stopping early crypto disks                                                        [OK]
mount: / is busy
 *Will now halt
[  58.914041] System halted.

It's been sitting like that for the last ten minutes as I typed the info into this answer on another computer. I presume it will stay that way all night. If you can help, I'd appreciate it. Thanks!

2
  • I'm the same guy who asked the question originally. I haven't used this site very much yet, but I guess I should have added the info under feedback instead. Sorry!
    – John Hill
    Jan 12 '13 at 4:30
  • I found the answer here: askubuntu.com/questions/125844/… It worked!
    – John Hill
    Jan 12 '13 at 5:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.