When I need to open a terminal I press Ctrl+Alt+T to save time. Most of the time absolutely nothing happens, I try to press same combination again, and still nothing happens. After like 5-8 tries terminal window finally appears. Sometimes terminal opens on a first try.

This is a very annoying situation.

I also noted that open rate increases when I click on random spot on my desktop when all windows are hidden.

Also, when terminal finally is open, next Ctrl+Alt+T combinations open new terminal window immediately.

There are no loadings when combination does not work, which means terminal will not appear even if I wait.

Ubuntu 12.10

Current computer: ASUS P5K-E/Wifi-AP MB, CPU Q6600 Quad Core @ 2.4ghz, GFX GTX560Ti, DDR2 RAM @ 800mhz 4gb

What am I doing wrong? Maybe there is some "focus" in shortkeys, global shortkeys, etc?

  • @vasa1 I tried with different keyboards on different computers, same story. When I run terminal via Dash or launcher terminal window appears immediately.
    – Maxim R
    Jan 11 '13 at 13:55
  • In other words, you have the same keyboard problem on totally different computers (with their own keyboards), but all running Ubuntu 12.10? By the way, do you have problems with any other shortcuts described here.
    – user25656
    Jan 11 '13 at 14:02
  • @vasa1 manufacturers of keyboards are different, but the problem is the same. Thanks for the link, I tried other shortcuts and everything works instantly once I try combinations. Problem always in opening terminal.
    – Maxim R
    Jan 11 '13 at 14:10
  • @Maxim_R it may be because the terminal is hidden behind another window. For some reason, I have found that my terminals start without focus when using ctrl-alt-t. I have to press alt-tab twice to get it in focus. Jul 23 '15 at 20:46

It may actually be working the first time, and is just taking a long time to appear. Try first opening System Monitor from the dash, and watching what happens when you hit Ctrl - Alt - T.

You can watch for CPU/memory spikes or for the process name (gnome-terminal, bash) to show up in the list. If that happens right away, then you know it's not a keyboard problem.

You may also be able to use 'xev' to debug whether the keys are being sent correctly.

My guess is that there is something in your .bash startup scripts that is doing a network lookup or something else slow, which is delaying the terminal's appearance.

  • I used the 'xev' to debug whether the keys are being sent correctly. When terminal windows appears instantly: keys: 53 0 0 0 32 0 0 0 1 0 0 0 0 And when keys did not work: keys: 4294967188 0 0 0 0 0 0 0 0 0 0 0 0 Also, when keys did not work I see in debug output after like 10 seconds or even more same output as If terminal was open. Full debug log: pastebin.ca/2301579
    – Maxim R
    Jan 12 '13 at 15:14
  • based on that, it seems like the keypress is not getting through. Can you try setting up a different keyboard shortcut to open a terminal, without using alt, and see if that one works? Jan 14 '13 at 17:56

Seems to happen if the gnome-keyring-daemon is ill-configured or there are two instances of it. Try verifying that the daemon is indeed running, and that the output of $ ps aux | grep keyring is somewhat similar to this:

user     2775 … /usr/bin/gnome-keyring-daemon --daemonize --login
user     4501 … /usr/bin/gnome-keyring-daemon --start --foreground --components=secrets
user     8808 … grep --color=auto -i keyring

If there are e.g. two processes started with the --daemonize --login arguments, you may have encountered a bug, one symptom being what you describe.

  • This is the case on my system. Suggestions on how to solve the issue?
    – Martin R.
    May 11 '17 at 15:54
  • No, I suspect my gnupg configuration is wrong, so maybe mv ~/.gnupg ~/.gnupg-bak? May 13 '17 at 15:23
  • This didn't help, but after running gnome-keyring-daemon --replace --foreground --components=secrets,ssh,pcks11 the system behaves as expected again. I still have to find a way, however, to fix the system permanently. In the worst case, I'll automatically run the aforementioned command on startup.
    – Martin R.
    May 16 '17 at 20:20

this going to sound silly but you actually have to press CTRL + ALT first and hold them and then press T at least a second holding both and then the third.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.