10

A new feature was added recently that adds an invisible border around the windows to grab for resizing (although i thought the new resize grip solved any big issues).

This annoys me because it destroys the usefulness of the grid plugin of compiz.. i'm not sure if the border is part of compiz or gnome, but i'd like to know how to disable it.

i couldn't find any options in ccsm or the window settings in gnome.

See the screenshot to see how much waste is caused. These windows should match up instead of having blank space surrounding all of them.

enter image description here

  • 1
    is this affecting also taking screenshots of windows, resulting in some pixels of the background around windows? – type May 8 '11 at 11:27
9

It's part of the theme.

Look into /usr/share/themes/Ambiance/metacity-1/metacity-theme-1.xml and change the padding properties to zero (or remove them), e.g:

<frame_style ...>
    ...
    <padding left="7" right="7" bottom="7"/>
</frame_style>

--- Update ---

There's now also a bug report to follow. The bug has been fixed, if you still see this, I'd report a new bug (unless it's happening with windows that can only be resized in fixed sized steps like gnome-terminal).

  • @Ike: np, if you want to change/disable the window, it's now also part of the theme (right above the padding lines) - except for the color, which still follows the window decorator plugin in Compiz. – htorque Jan 30 '11 at 21:09
1

Simpler solution: run gtk-window-decorator --replace & in a terminal. Only unity-window-decorator supports this theme option but gtk-window-decorator supports the rest of the metacity theme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.