I'm running Ubuntu 64 bit 12.04.1 LTS. I see either a blinking cursor or a black screen if I try to boot all kernels beginning at 3.2.0-33 and later. Safe mode fails for those kernels as well.

However, my system boots fine and runs fine on kernel 3.2.0-32 as well as kernels previous to that.

I have seen other Z580 users with this same problem on other forums.

Thank you.


I'm running 64 bit Lubuntu 12.10 on my Z580 and managed to fix the booting issue using the approach described here.

The steps that I followed are:

  1. Installed iasl

    sudo apt-get install iasl
  2. Made a copy of the DSDT file.

    sudo cp /sys/firmware/acpi/tables/DSDT ~/DSDT
  3. Decompiled the DSDT file to a .dsl file

    sudo chmod +r DSDT
    iasl -d DSDT
  4. Edited the DSDT.dsl to add a small sleep command in the WAEC method.

     Method (WAEC, 0, NotSerialized)
        Name (CUNT, 0x1E)
        While (LNotEqual (^PCI0.LPCB.EC0.BYFG, Zero))
            Sleep (0x05)
            Decrement (CUNT)
            If (LEqual (CUNT, Zero))
                Store (Zero, ^PCI0.LPCB.EC0.BYFG)
                Store (Zero, ^PCI0.LPCB.EC0.DRFG)
        Sleep (50) // #### adding this line is the only change ####
  5. Produced a .aml file from DSDL.dsl

    iasl DSDT.dsl
  6. Copied to .aml file to the /boot directory

    mv DSDT.aml dsdt.aml
    sudo cp dsdt.aml /boot/
  7. Added the .aml file to the grub configuration using the method described here. First downloaded the 01_acpi.txt file. Then:

    mv 01_acpi.txt 01_acpi
    chmod +x 01_acpi
    sudo mv 01_acpi /etc/grub.d
  8. Updated grub configuration

    sudo update-grub2
  9. Once I rebooted the problems disappeared.

    sudo reboot

My current kernel version is 3.5.0-17-generic. Not sure what happens on newer kernels.


On Z580, kernel 3.2.0-35 boots but it takes 12-13 minutes. dmesg shows timeouts and errors in acpi. Booting with acpi=off kernel parameter results in faster boot but maybe a less restrictive setting can be found.

  • I did not want to disable acpi since so much may depend on it. So for now I am just living with the 13 minute cold boot - otherwise everything appears to work normally. – user1910238 Jan 15 '13 at 14:26
  • This is a consistent problem for Z580 owners. I have found several related threads: – user121324 Jan 31 '13 at 16:07
  • Disabling ACPI seems a rather awful solution because I have read that hyperthreading is sacrificed. We ought to be able to use it. For now I am running an old kernel and refusing to update. Related threads: link ; link ; link – user121324 Jan 31 '13 at 16:14

I use Ubuntu 12.10 amd64 and had same problem.

I updated to kernel version 3.8.1 with following howto http://www.adminlife.net/howtos/linux-kernel-backen-the-debian-way/

Now the laptop starts without problems and ACPI support.

  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – user98085 Mar 3 '13 at 17:33
  • Hi, I would like to tell everyone that, out of curiosity, I compiled and installed kernel 3.8.1 too. This kernel boots sometimes, but never twice in a row. When it boots there are no problems with acpi!! But more than 50% of the time it has the same long lag (> 10 min) or non-boot (in all cases, just a black screen) as kernels 3.2.0-33 through 3.2.0-38 (the last one I have tried). So, clearly the 3.8.1 kernel is capable of functioning fine, but I am totally unclear as to why it more often does not boot. – user121324 Mar 25 '13 at 22:18
  • Confirming that kernel 3.8.1 doesn't resolve the problem. A fix has been submitted, but it requires hacking DSDT for the time being: bugs.launchpad.net/ubuntu/+source/linux/+bug/1093217/comments/… – pushka Mar 27 '13 at 9:14
  • Hello, a very belated follow up. I confirm that the fix posted by user pushka works for me (see link he has posted, March 27). Boot delays are fixed. Thank you, very, very much. – user121324 May 30 '13 at 2:43
  • Glad it worked. Out of interest, did you get any warnings when you recompiled DSDT? I got some 'Unknown reserved name' warnings so didn't go any further. Maybe they are just trivial... – pushka May 30 '13 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.