I am on Ubuntu 12.10 and for some reason my wireless connection is using WEP when it is set to use WPA/WPA2 Personal.

Also I should mention that I used to be on 12.04 and was experiencing the wireless connection automatically creating a different wireless connection profile that used WEP. It showed up as Siddhion1 and I would always have to deleted it from my Network Connections list. So it seems that this problem has migrated to 12.10 maybe because I upgraded and did not do a fresh install?

Anyways, as you can see from the following screen shot of my Network Connection "Siddhion", its security is set to WPA & WPA2 Personal.

enter image description here

When Siddhion is automatically connected to the Network window shows that Siddhion's security is in fact WEP (shown in the following screenshot)

enter image description here

Obviously this is a big concern since WEP has poor security. I ran a following diagnostics commands to get the following results.

hwinfo --netcard

max@siddhion:~$ hwinfo --netcard
> hal.1: read hal dataprocess 29274: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 282.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
26: PCI 200.0: 0282 WLAN controller                             
  [Created at pci.318]
  Unique ID: y9sn.ReL4kyurUv5
  Parent ID: z8Q3.1xIyAHITO_C
  SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Intel Wireless WiFi Link 5100"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x4232 "Wireless WiFi Link 5100"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x1201 
  Driver: "iwlwifi"
  Driver Modules: "iwlwifi"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0xc0000000-0xc0001fff (rw,non-prefetchable)
  IRQ: 45 (1214675 events)
  HW Address: 00:22:fa:2c:3d:4c
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68 5.7
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v00008086d00004232sv00008086sd00001201bc02sc80i00"
  Driver Info #0:
    Driver Status: iwlwifi is active
    Driver Activation Cmd: "modprobe iwlwifi"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

27: PCI 300.0: 0200 Ethernet controller
  [Created at pci.318]
  Unique ID: rBUF.5Jtq7eCSpW3
  Parent ID: qTvu.3mBS8QXtRlD
  SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Marvell 88E8040 PCI-E Fast Ethernet Controller"
  Vendor: pci 0x11ab "Marvell Technology Group Ltd."
  Device: pci 0x4355 "88E8040 PCI-E Fast Ethernet Controller"
  SubVendor: pci 0x1179 "Toshiba America Info Systems"
  SubDevice: pci 0xff50 
  Revision: 0x12
  Driver: "sky2"
  Driver Modules: "sky2"
  Device File: eth0
  Memory Range: 0xc0500000-0xc0503fff (rw,non-prefetchable)
  I/O Ports: 0x3000-0x3fff (rw)
  IRQ: 44 (1 event)
  HW Address: 00:23:8b:80:9a:2c
  Link detected: no
  Module Alias: "pci:v000011ABd00004355sv00001179sd0000FF50bc02sc00i00"
  Driver Info #0:
    Driver Status: sky2 is active
    Driver Activation Cmd: "modprobe sky2"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #16 (PCI bridge)


max@siddhion:~$ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"Siddhion"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:AA:AA:10:12:EB   
          Bit Rate=11 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-31 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:184   Missed beacon:0

sudo iwlist wlan0 scan

max@siddhion:~$ sudo iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 00:AA:AA:10:12:EB
                    Frequency:2.462 GHz (Channel 11)
                    Quality=70/70  Signal level=-35 dBm  
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Extra: Last beacon: 56ms ago
                    IE: Unknown: 00085369646468696F6E
                    IE: Unknown: 010482848B96
                    IE: Unknown: 03010B
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD0700E04C01020300

Additionally I ran wpa_gui to see if WPA was being recognized and the status message I see is

Could not get status from wpa_supplicant

as shown in the following snap shot

enter image description here

Does anyone have an idea on how I can make Ubuntu use only WPA & WPA2 security?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.