I have a Bluetooth headset connected to my computer. The buttons play/pause/volume are working fine, but I have no sound in the headset. It only works in the speaker of the computer.

In fact, I played with the sound settings of my headset in the sound settings of Ubuntu, and after choosing "switch off", the headset did "disappear" from the settings.

My question is: how can I make it appear there again, to be able to hear the sound via the headset? Thank you all for your help!

  • 11
    Did you check sound settings and confirm the correct 'output' is selected? For some more setttings I would advice to install pavucontrol. It saved me some troubles diagnosing sound issues.
    – Rinzwind
    Commented Jan 9, 2013 at 21:07
  • Yes, that's it, it works, THANK YOU VERY MUCH. I found the headset in pavucontrol and was able to turn it on again - it was not visible in the "sound settings" after i did choose the "switch off" profile - that is to correct by ubuntu i guess. Thank You again.
    – imago
    Commented Jan 9, 2013 at 21:32
  • Here you go @imago :) Glad it worked out!
    – Rinzwind
    Commented Jan 9, 2013 at 21:42
  • 1
    Already answered this exact duplicate q: Accidentally changed Bluetooth mode to off
    – gertvdijk
    Commented Jan 9, 2013 at 21:46
  • possible duplicate of Accidentally changed Bluetooth mode to off Commented Jan 10, 2013 at 0:07

10 Answers 10


For some more settings I would advice to install pavucontrol. It saved me some troubles diagnosing sound issues. It also will list any possible output where Ubuntu sound sometimes forgets to show outputs that should be available (though it keeps getting better: HDMI used to not show up; 1 update after 12.10 release it started showing up.

You too will be able to find your headset and control it from here.

If I recall correctly after I used pavucontrol to activate my hdmi ubuntu control picked it up too (but that might have been caused by an update too). Otherwise do not use Ubuntu sound settings but switch to this program since it also has far more options.

enter image description here

Command line install

sudo apt-get install pavucontrol
  • 9
    The bluetooth device doesn't show up as an output. That's the problem...
    – Cerin
    Commented Jul 3, 2015 at 2:07
  • 5
    Worked for me immediately, though I had to enable the headset first on this screen: screenshot Commented Jul 26, 2016 at 8:08
  • I'm trying to get this to work, and although the BT headset shows up on the configuration screen in PAVU, any change from the 'off' setting isn't saved by PAVU.
    – JamesBB
    Commented Apr 6, 2017 at 7:45
  • This works while the default audio control on Kubuntu fails to let me switch playback device. It still doesn't show my HDMI outputs though (while the default sound control settings in Unity worked).
    – xji
    Commented Jan 28, 2018 at 21:29
  • Worked for me. My issue was there was another sound adapter and sound was directed to that. PulseAudio can list down all adapters and show the flow.
    – Sudheera
    Commented Jul 31, 2018 at 5:56

Try this script: a2dp.py

Install using:

curl "https://gist.githubusercontent.com/pylover/d68be364adac5f946887b85e6ed6e7ae/raw/install.sh" | sh

The installation script will copy a2dp.py into PATH and make it executable. So, you may issue this command to use the a2dp.py script:

$ a2dp.py 
Connection MADE
Selecting device:
1. 00:22:37:3D:DB:1A JBL E40BT
2. 00:22:37:3D:DA:50 JBL E40BT
Select device[1]: 2
Device MAC: 00:22:37:3D:DA:50
Device ID: bluez_card.00_22_37_3D_DA_50
Sink: bluez_sink.00_22_37_3D_DA_50
Turning off audio profile.
Disconnecting the device.
Connecting againt.
Setting A2DP profile
Device ID: bluez_card.00_22_37_3D_DA_50
Updating default sink
Exiting bluetoothctl
  • 3
    The ultimate script !! Wonderful, thanks pylover
    – eouti
    Commented Jan 1, 2017 at 22:03
  • 2
    Many thanks, this is golden. Canonical, come and look at this please! Commented Mar 7, 2017 at 20:19
  • 1
    I have been stuck for 2 days with no audio, this script fixed it all up, thanks! :D
    – PKKid
    Commented Dec 14, 2018 at 14:08
  • 1
    Wow, it worked!! I got an error "Cannot find bluez_card.F8_DF_15_B4_0B_47 using pactl list cards short" 15 times in a row and figured this was another dead end, but the script ended up pairing my bluethooth speaker and it works perfectly. Thank you thank you thank you!! I've been struggling with this for so long.
    – Greg H
    Commented Feb 10, 2019 at 19:16
  • 1
    This worked for me only after I removed my device and re-added it.
    – Dagelf
    Commented Nov 12, 2019 at 8:58

Terminating the PulseAudio daemon with pulseaudio -k did the trick. Headset started appearing.

-k | --kill

Kill an already running PulseAudio daemon of the calling user (Equivalent to sending a SIGTERM).

  • 1
    Found solution here: askubuntu.com/a/372111/13330 Commented May 26, 2016 at 7:27
  • 3
    I don't full understand, how this worked. But it is working! (I did purge pulseAudio and start over) Thank you! Ubuntu is awesome, but this bluetooth issue needs to be resolved, it's 2017!
    – Chad
    Commented Jul 14, 2017 at 5:16
  • I think pulse audio has some issues with detecting the bluetooth headphones as an output (especially when there's more than 1 audio profile)
    – user5245
    Commented Aug 1, 2019 at 13:23
  • This also fix similar issue with USB connected "Jabra Evolve 30" jabra.com/business/office-headsets/jabra-evolve/…
    – Pascal
    Commented Oct 3, 2019 at 6:17

With the latest Ubuntu version (15.10) the Bluetooth headphones are recognized but not available in pavucontrol. After some testing I found this simple solution to enable it!

Install the bluetooth package then restart the bluetooth service and now the headphones are visible.

sudo apt-get install bluetooth

after this

sudo systemctl restart bluetooth

Note: you may need to turn your headphones off and on again after these commands.

  • Worked for me. Ubuntu 18.04, Thinkpad P43s
    – Ddorda
    Commented Apr 14, 2020 at 9:32
  • I did this. It asked Enter Private Key Password:, I did not look but assumed it was asking for sudo so I entered my password (two times). Now, the bluetooth does not work any more at all on my Dell Latitude...
    – bomben
    Commented Jun 4, 2020 at 7:26
  • Worked for me on Ubuntu 20.14.1 Commented Sep 21, 2020 at 12:07
  • This ended up getting it fixed on my laptop as well as my gf's laptop both running Ubuntu 20.04. On mine I had issues with A2DP but not on hers. I had been troubleshooting on hers first but then she needed the laptop so maybe pavucontrol was the missing piece. Commented Jan 2, 2022 at 16:25
  • This helped me resolve a problem on Ubuntu 20.04 with my new EarFun wireless earbuds where I could connect them to bluetooth but they would not show up in the Output Device dropdown under Sound settings. Thanks!
    – klenwell
    Commented Jul 23, 2022 at 15:40

(This issue has bothered me for a long time, and I just found the solution, it worked on my laptop.)

I am using Mint mate 18, which is based on Ubuntu 16.04. To make headset & ubuntu/mint work together, need both blueman and pulseaudio.

Connect & choose output device


  • sudo apt-get install blueman
    Install blueman.
  • blueman-manager &
    Start blueman, and enable bluetooth as tip, if not yet.
  • Start your headset device, make sure it's not connected to other device yet.
  • In blueman:
    • Search device.
    • Right click headset -> trust, if not yet.
    • Right click headset -> pair, if not yet.
    • Right click headset -> audio sink.
    • And wait a bit for it to connect.
  • sudo apt install pavucontrol
    Install pavucontrol.
  • pavucontrol &
    Start pavucontrol.
  • In pavucontrol.
    • In playback tab.
    • Find a outputer, e.g chromium.
    • Choose the headset device as it's output.
  • Play some music in your chrome browser.
  • Now your headset should be playing chrome's sound.


  • In pavucontrol, for each outputer (e.g chromium), could choose which device to use.
    By default, it's usually the computer's built-in audio, not your bluetooth headset.
  • Each time bluetooth connected, need to choose which device to use in pavucontrol again.

Command shortcut

Add to .bashrc:

## bluetooth headset related,
alias btmanager="blueman-manager &"
alias btctrl="pavucontrol &"

It's really convenient

Next time, I want to get some drinks or snacks, I could just walk away, without needing to unplug the wired headset, and without interrupting the music or video I am listening to, really convenient.

Cheers !!!

  • What's the down vote for ? Is this answer not working or do you think it's duplicated with others ???
    – Eric
    Commented Oct 30, 2019 at 6:56

I am relatively new to the Linux world, but have had no major issues converting from Windows. Please be patient with my explanation because I wrote it with a brand new person to Linux in mind. I have fallen in love with Linux and wish for other "newbies" to do the same :)

For someone converting from windows... powerful "sudo" commands that are entered without understanding of their meaning... may quickly lead to a fresh re-install of one's favorite flavor of Linux. I speak from experience. If you are new to Linux, especially switching from Windows, it is important to know that not all hardware is compatible and to make it even more interesting, Linux “distros” are also not equal. I am currently using Linux Mint 17.1 KDE, which is more or less a derivative of Canonical's Ubuntu. For example, if you didn't know, most HP printers are recognized immediately and effortlessly within Linux because of the the wonderful HPLIP opensource project. Just connect and turn on your HP printer, then go to printer settings within Ubuntu or Linux mint 17.1 and simply add your HP printer (which should be already listed).

A little research first will definitely save a huge headache later. :)

I tried using my Insignia Bluetooth Receiver in the past, but had no luck on Mint or Ubuntu, while my newly bought Kensington Bluetooth 4.0 dongle #K33956AM was recognized and paired seamlessly with my other devices. It was able to list the exact device name along with the MAC address. Unfortunately, I had NO SOUND. :( I double checked it was not my system. My computer played the music file normally though my built-in analog stereo hardware. :(

I read what the awesome and helpful people stated above, but went though the graphical interface instead of using the terminal (I've used windows for the past 20 years, what can I say... LOL) I went to System Settings/Multimedia/Audio and Video Settings and discovered my Analog stereo hardware received priority over my Bluetooth hardware. I first attempted to change the priority of the devices within the "Audio Playback Device Preference for 'Music' Category" but this did not fix my sound.

THEN I DISCOVERED THE SOLUTION TO MY PROBLEM... I changed the priority of devices in the "Audio Playback Device Preference for 'Video' Category" and BINGO!!! :) :) :) This worked perfectly. For some reason the video setting also controls the music. I changed all pertinent settings to make my Bluetooth have priority and have not had any further issues since that point. Hope this helps. :)

Pulse Audio Volume Control is Pre-installed on Linux Mint 17.1 (. This is a great tool. Just search in the menu bar for the program or use the PPA from the repository a.k.a. Software Manager. Although I should mention, this program would not work for me until after I changed the settings in the Multimedia.


  • Where in Mint did you find System settings/Multimedia/Audio and Video? I am using 17.3 (Rosa) and can not find 'multimedia' anywhere off the menu.
    – RyanNerd
    Commented Feb 24, 2016 at 6:35

Thanks CPlovlin, this is the one last config step I was missing. My Bluetooth headset works much better in Debian than in Windows 10. I had short range when using Windows and it cut out a lot. In Debian Jessie, I have nearly double the range.

For others using Debian or Ubuntu. Here is what I did to get my Bluetooth dongle to work and my headset configured.

1.) First I plugged my USB Bluetooth Dongle into my computer. After that I did a quick check to see if it was recognized.

sudo lsusb

2.) Open up terminal, you will need to install a few things.The following meta-package has most of what you will need. Don't forget sudo or su.

sudo apt-get install bluetooth

3.) Now we need an applet in the tool bar at the bottom. For KDE, I did this (if you are using a different window manager, you may wanna look for whichever will work best for you:

sudo apt-get install bluedevil

4.) I then had to add the blue tooth software to get the volume control to have the bluetooth modules needed.

apt-get install pulseaudio pulseaudio-module-bluetooth pavucontrol bluez-firmware

5.)After that, you should just probably do a quick reboot. Do either of the following: sudo reboot


sudo systemctl restart bluetooth

You should have a bluetooth icon in your system tray. Now just right click and choose 'Add Device'

Now that your bluetooth is all set up, make sure to follow what CPlovin said above. Just because your testing out an mp3, make sure that your headphones are the preferred device for video and audio. I just set it to be my preferred device for everything.

Hope this helps others!

  • 1
    Thanks for your help ! Make sure you restart pulseaudio service after installing pulseaudio-module-bluetooth using systemctl --user restart pulseaudio.service Commented Oct 6, 2021 at 14:18
  • This worked for me on Ubuntu 22.04.2 LTS. Thanks!
    – onit
    Commented Apr 15, 2023 at 13:21

if not already installed install pulseaudio-module-bluetooth, this will add the required pulse audio sink that is needed.

sudo apt-get install pulseaudio-module-bluetooth

Afterwards restart pulse

pulseaudio -k
pulseaudio --start

Then make sure in the bluetooth manager your headset is connecting to the audio sink. At this point it should also appear in pacucontrol, make sure it uses the high quality audio protocol.

  • Not enough, it needs to load the module. pactl unload-module module-bluetooth-discover; pactl load-module module-bluetooth-discover
    – WitchCraft
    Commented Jun 22, 2022 at 20:18

The buttons play/pause/volume are working fine, but I have no sound in the headset. It only works in the speaker of the computer.

We need to make sure we have:

  • Connected our headphones to bluetooth properly.
  • Configured our computer to output audio to our headphones.

Connect your headphones to Bluetooth Properly

We will use the bluetoothctl command-line utility:

  • Important: Make sure your device is bluetooth discoverable by pressing some button on the device.
  • Find the bluetooth device's MAC-address by running $bluetoothctl scan on.
    • This command will start discovering your devices and you need to spot your device's mac address in the output. My device is called "Avi Ear" and it was found in the line:
      • [CHG] Device 4C:87:5D:9E:04:B8 Name: LE-Avi Ear
    • From the above output, we know that my device's MAC address is 4C:87:5D:9E:04:B8.
  • Now that we have the MAC address, we can connect to the device with the following bash script AFTER replacing my MAC address with yours:
    • Important: Before running the script, make sure your device is bluetooth discoverable by pressing some button on the device.
# remove headphones and start fresh
bluetoothctl remove 4C:87:5D:9E:04:B8
# turn bluetooth off
bluetoothctl power off
# turn blutooh on
bluetoothctl power on
# scan for devices for 15 secs so that our device gets discovered.
timeout 15s bluetoothctl scan on
# pair with headphones
bluetoothctl pair 4C:87:5D:9E:04:B8
# trust headphones
bluetoothctl trust 4C:87:5D:9E:04:B8
# connect to headphones
bluetoothctl connect 4C:87:5D:9E:04:B8
  • Finally, you should see headphones in the "Connected" state in Bluetooth Settings. For example, as you can see in the image below, "Avi Ear"(Name of my headphones) is "Connected". enter image description here

Configure your computer to output to your headphones

Even though my headphones were shown as connected, I did not hear any sound. To hear sound you need to:

  • Open the PulseAudio Volume Control App. This came preinstalled with Ubuntu for me, but you should be able to find easy instructions to install if you don't have it.
  • Go to the Configuration tab and make sure you have all other devices turned off except your headphones like this: enter image description here

You should now be able to hear sounds from your headphones now.

  • 1
    god bless you! finally fixed the issue with bluetooth speaker
    – devnull Ψ
    Commented Jan 7, 2023 at 15:05
  • @devnullΨ I am so glad it helped! :D :D Commented Jan 8, 2023 at 5:46

The problem is that pulseaudio didn't load the module bluetooth-discover.

So you simply need to load the module

sudo pactl unload-module module-bluetooth-discover;
sudo pactl load-module module-bluetooth-discover

You also need pulseaudio-module-bluetooth installed

sudo apt-get install pulseaudio-module-bluetooth

Restarting pulseaudio-daemon was not even necessary.

I could google the problem after I got "protocol error" after I installed blueman.

sudo apt-get install blueman

See here.
Blueman seems to be more helpful than the KDE bluetooth-manager.


root@asshat:~/# dpkg --search `which pactl`
pulseaudio-utils: /usr/bin/pactl

The underlying problem is that module-bluetooth-discover is not loaded with


only with


which is not used if pulseaudio runs with --system (when you run it as root).


.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover

to that file (/etc/pulse/system.pa), and you should be fine.

  • This, with the addition of also adding .ifexists module-bluetooth-policy.so load-module module-bluetooth-policy .endif worked for me
    – Bruce
    Commented Dec 8, 2022 at 3:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .