I am running XBMC, which is built around Ubuntu 10.04. It does not come with samba pre-installed, and I need to share some media with a couple other boxes. I followed the Think Geek directions found here. I had it all set up a couple days ago, and thought I was in the clear. I rebooted this evening and when it came back up Samba was not started. I determined this by trying access the samba shares, and it would return there was an connecting to the server. I can ssh into it, so I know it is connected.

In my inifinite wisdom, I figured I just messed something up and would just uninstall and reinstall. So I did: sudo apt-get purge samba and sudo apt-get purge smbfs. Then tried to follow the tutorial above again.

The what I get after running sudo apt-get install samba smbfs is

Reading package lists... Done 
Building dependency tree
Reading state information... Done 
Suggested packages:   openbsd-inetd inet-superserver smbldap-tools ldb-tools ufw smbclient 
The following NEW packages will be installed: 
samba smbfs 
0 upgraded, 2 newly installed, 0 to remove and 5 not upgraded. 
Need to get 0B/8,131kB of archives. 
After this operation, 22.6MB of additional disk space will be used.
Preconfiguring packages ... 
Selecting previously deselected package samba.
(Reading database ... 57098 files and directories currently installed.)
Unpacking samba (from .../samba_2%3a3.4.7~dfsg-1ubuntu3.2_i386.deb)... 
Selecting previously deselected package smbfs. 
Unpacking smbfs (from .../smbfs_2%3a3.4.7~dfsg-1ubuntu3.2_i386.deb) ... 
Processing triggers for ureadahead ...
Setting up samba (2:3.4.7~dfsg-1ubuntu3.2) ...
Generating /etc/default/samba...
update-alternatives: using /usr/bin/smbstatus.samba3 to provide /usr/bin/smbstatus (smbstatus) in auto mode. 
smbd start/running, process 2963
**start: Job failed to start**

Setting up smbfs (2:3.4.7~dfsg-1ubuntu3.2) ...

The bold is my own emphasis. So I am not sure what I messed up here, or how to get back to where it was. Though I am pretty sure I made it worse than it is.

I found where the logs are located, /var/logs, and found this line that seems to be the culprit.

Jan 29 11:59:34 XBMCLive smbd[2806]:   error opening config file

So it seems to not create the configuration files. Is there a way to get samba to try to recreate them again?


The package that owns /etc/samba/smb.conf is samba-common - You should be able to copy the config from /usr/share/samba/smb.conf if /etc/samba/smb.conf is missing & then run dpkg --configure samba-common

  • I actually just needed the smb.conf file apparently. I put the defualt in there, and restarted it, and it worked. Thanks Jan 31 '11 at 18:43

What you wanna do is, use autofs:

apt-get install autofs
apt-get install smbfs
vim /etc/auto.master

/smb /etc/auto.mysmb --timeout=10 --ghost

sudoedit /etc/auto.mysmb

videos -fstype=smbfs,username=USERNAME,password=PASSWORD ://192.168.0.xxx/Videos
music -fstype=smbfs,username=USERNAME,password=PASSWORD ://192.168.0.xxx/Music/Collection

/etc/init.d/autofs reload

Of course replace the xxx with your IP of your NAS and your own user/pass...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.