I have installed Ubuntu 12.04 Desktop amd64 on my Lenovo ThinkPad E330. There were no problem during installation. Now I can boot to Ubuntu and use it.

BUT: now there is only one option in Boot Devices in my ThinkPad's BIOS:

  1. ubuntu

I can boot ThinkPad to Ubuntu on HDD ONLY - no other options. I switched BIOS to "Legacy devices only" - this did not help :(

Could you, please, help me and explain how to boot my ThinkPad from USB drive? How can I switch back to Legacy devices and use MBR, not UEFI?

Thank you!

  1. Change in BIOS settings "fast boot" from enabled to diagnostics.
    Keep "Boot settings" in both but Legacy first
  2. Connect your USB stick to the usb3-port next to SD-Card reader
    (i head frequently issues to have it recognized by the BIOS in the other port..)
  3. Save BIOS settings with F10
  4. Press ENTER during reboot
  5. You should arrive on a option frame, PRESS ENTER AGAIN to stop countdown. Wait 5 Seconds or so, to have all the devices recognized in background.
  6. Now choose with F12 "choose temporaly startup device", choose something like USB or flash

NOTE: if you won't find your usb stick here, reboot and change bios settings for "Network Boot" and reboot and switch "Network Boot" again back to "Realtek.." and reboot. The Bios is behaving real strangely. Start again with No. 1.)

Good Luck, Mike

b.t.w. if you did a dual boot set-up with both, Windows and Ubuntu, check this out: https://help.ubuntu.com/community/Boot-Repair

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.