Has anyone successfully installed Ubuntu (or any other flavour of Linux) on an Intel X79 (Sandy Bridge-E) based system?

My system build is:

  • MSI Big Bang XPower II
  • Intel Core i7 3930K processor
  • 32GB Corsair Vengeance RAM
  • EVGA GTX 670 FTW graphics card
  • 4x2TB hard drives in RAID 10
  • Samsung 830 Series 2x64GB SSD in RAID 0
  • Samsung 830 Series 128GB SSD

I am trying to install Ubuntu on the 128GB SSD and I seem unable to successfully boot Ubuntu. Here's what I've tried:

  • booting from a USB flash drive as well as DVD media
  • UEFI turned on, UEFI turned off
  • appending nomodeset acpi=off to boot parameters
  • turning off all Intel stepping
  • changing power control settings
  • Ubuntu 12.04 LTS
  • Ubuntu 12.10
  • Linux Mint 13
  • disconnecting all hard drives except 128GB SSD

Nothing from the combinations of these seem to matter - I simply can't get it to boot. It gets stuck in the same place showing this screen during the boot cycle and the only way out of it seems to force it to shut down.

I would appreciate any help on this.

  • 1
    Ah, okay. In that case, keep it to one question at a time. You appear to have two unrelated issues. 1) How to boot from USB? <-- is this in general or only regarding Ubuntu Live images? 2) Should I use Intel Matrix RAID in my dual-boot setup with Windows? <-- Ask in another Question! And please edit your original question for new information. – gertvdijk Jan 8 '13 at 20:53
  • We really need more information. Here's stuff to include in your question: 1) What have you tried? 2) What did you expect to happen, but what happened instead? 3) Do other bootable media boot up? 4) What exact motherboard is it concerned? 5) What makes you think this is Ubuntu related? 6) anything else that might help. And consider removing the now no longer relevant comments. – gertvdijk Jan 8 '13 at 21:10
  • Did you try to boot 12.10 (I assume 12.04 from the tag)? With a more recent kernel in 12.10 should support the hardware. Give that a try. Do you have the latest (1.5?) BIOS installed on it? (Sorry for the Sandy/Ivy confusion you've fixed up now!) – gertvdijk Jan 8 '13 at 21:40
  • stuck in the boot cycle - is it blank screen? Maybe acpi related? – Drake Clarris Jan 8 '13 at 21:48
  • @JerryHolland This is essential information for a question to be answerable. It should have been in your question from the beginning. Please keep in mind that we can't see your screen and other activity you do there. It's of your own advantage to describe as much and complete as possible. Back to your issue: Try booting with nomodeset acpi=off (both, space separated) appended to the kernel boot parameter line. Here's how: My computer boots to a black screen, what options do I have to fix it? – gertvdijk Jan 8 '13 at 22:00

After many failed attempts I successfully got Ubuntu to boot on my computer by disabling the external SATA controller on my motherboard. I booted successfully with:

  • Intel Stepping on
  • UEFI on
  • ASMedia ASM 1061 OFF

However, after this successful boot I began by turning the ASMedia controller back on AHCI mode and unplugging the four devices from the motherboard that use these ports, which successfully booted as well. Through trial and error I discovered the problems occurred when my CD/DVD drives were plugged in. I have two LG GH24NS95 drives that appear to be the cause of my problems from the beginning.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.