I am currently stuck using both Python2.6 and Python2.7 on Lubuntu 12.10. 2.6 is required for a piece of software.

In attempting to write a plug-in for this software (Opticks), I need to be able to access PyQt4. Using apt-get install python-qt4 I get a perfectly working installation for 2.7...

I have tried altering the default python version and changing the soft link in /usr/bin to 2.6. No joy. Pip-2.6 and easy_install-2.6 are also unable to install PyQt4 due to the lack of a setup.py file.

I was able to get this functioning using the suggestion from @dobey and a link on compiling pyQT for python2.7. In the link, simply change ally python2.7 calls to python2.6.

  • Can you please clarify what Opticks is with a link to its home page perhaps? – dobey Jan 8 '13 at 17:08
  • opticks.org – Jzl5325 Jan 8 '13 at 18:55
  • I downloaded the deb from there, and it runs just fine for me on Ubuntu 13.04, and doesn't seem to require Python at all. The build system is a bit crazy, and it includes its own versions of some libs, but otherwise seems to work OK for me. – dobey Jan 8 '13 at 19:30
  • They are shipping python as an extension, so the issue only arises if you want to script for Opticks in python. opticks.org/confluence/display/opticksExt/Python+Scripting – Jzl5325 Jan 8 '13 at 19:38

To use PyQt with Python 2.6 on Ubuntu 12.10, you will need to rebuild a custom PyQt against Python 2.6, as it is a compiled module, and not written in Python.

To use Opticks with the Python extension for it, on newer versions of Ubuntu, it will need to be ported to 2.7 upstream, and built against 2.7; include it's own version of everything required, or you'll have to build all the dependencies that are needed, yourself. Their Python extension seems to only work with Python 2.4, 2.5, or 2.6.

If you don't wish to compile everything yourself, you'll need to get support from the Opticks developers or community.

| improve this answer | |
  • 2.6 is a requirement for the built-in Opticks interpreter. Not my code or my idea. I do not see any 2.6+ modules being used, but they are pegged to 2.6 for now. – Jzl5325 Jan 8 '13 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.