I just installed cairo-dock and was changing some settings. I tried to change the theme to Mac OS X, which I placed in ~/.config/cairo-dock/themes/Mac OS X/ after which my cairo dock doesn't display at all. I have been using it in OpenGL mode, changing it to non-OpenGL doesn't seem to help (same problem). I have tried removing the package configs (using ubuntu tweak) and then reinstalled cairo-dock and cairo-dock-plug-ins, and restarted several times but still, when I start cairo-dock - same problem again. When I start cairo dock, this is what displays on my desktop (instead of showing the dock). How can I make it work?

This is how my dock looks:


Notice the little line inside the red ellipse? That's the dock. No icons or anything. Click also doesn't work.

This is what it shows when I run cairo-dock from terminal. I have removed bunch of Gtk warnings before this verbose for simplicity.

    (cairo-dock:6241): Gtk-WARNING **: Theme parsing error: nautilus.css:157:21: Not using units is deprecated. Assuming 'px'.

(cairo-dock:6241): Gtk-WARNING **: Theme parsing error: nautilus.css:173:20: Not using units is deprecated. Assuming 'px'.
warning :  (/build/buildd/cairo-dock-3.1.2/src/gldit/cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:208)  
  couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...

    Cairo-Dock version : 3.1.2
    Compiled date      : Dec  2 2012 00:22:04
    Built with GTK     : 3.6
    Running with OpenGL: 1

g_key_file_set_string: assertion `string != NULL' failed
Unity-Bridge: registered as Unity: <dbus.service.BusName com.canonical.Unity on <dbus._dbus.SessionBus (session) at 0x2323890> at 0x2330c90>
-> connected to cairo-dock
('new owner:', dbus.UTF8String(':1.190'))
warning :  (/build/buildd/cairo-dock-3.1.2/src/gldit/cairo-dock-surface-factory.c:cairo_dock_create_surface_from_image:440)  
  This file (/home/jared/.icons/Leopard_Icons_v0.3/EXTRAS/More/QuickTimePlayer.png) doesn't exist or is not readable.

Note: I don't know where that "jared" came from. Thanks in advance!

1 Answer 1


Okay, got this problem solved by myself. :D

Launch cairo-dock in maintenance mode from command line like this:

cairo-dock -m

As the cairo-dock --help puts it, this mode is used to Allow editing of the configuration before the dock is started and show the config panel on start.

Disabling the recently messed up settings in the window that shows up, should launch the Cairo dock normally.

In my case, the theme I downloaded was an outdated one, and it had some icons in it probably missing, and when the dock launched, it was probably searching for the missing icons (like the terminal verbose says it). I had to disable it from the maintenance mode to get my dock back. :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .