My setup

First off, my apologies if this is a duplicate but I could not find anything specific regarding my graphics card.

So as the title states, I have purchased a new laptop with an AMD Radeon HD 7640G graphics card. (detailed specifications).

I was able to install Ubuntu on the laptop without any problems whatsoever. My next step was enabling the proprietary drivers (Catalyst 12.11) from the Additional drivers menu (jockey). That's where I got stuck.

The Open Source drivers do not appear to support the graphics card mode

The problem

After installing FGLRX, my notebook now doesn't boot up properly anymore. It displays the splash screen but then gets stuck in a shell. At this point I am not able to enter any commands so I'm forced to do a hard reboot and get into recovery/low graphics mode.

Shown in this image below:

After Catalyst 12.11 driver install

I would love to make FGLRX work.

What I've tried so far

I followed the instructions provided by this Q&A and the official Ubuntu guide, but to no avail. Both sources offer the same basic steps, which I think I took:

  • Get the latest catalyst driver from AMD website (Catalyst 12.11 beta 8),

  • Set the .run file to be able to execute (chmod etc)

  • run it in terminal

  • initialise the driver by: sudo amdconfig --initial -f or sudo aticonfig --initial -f

  • Reboot

Is there anything I'm overlooking. Any suggestion on what I might be doing wrong? Or is there maybe another way of installing FGLRX?

I might not have provided enough details in this post. So if there's any other information you need to help me with this problem, please let me know and I'll be glad to add it.

Right so an update. I have managed to install the 12.10 driver from catalyst and when I reboot, I get the login screen etc. After I log in, it loads my desktop background, but it does not appear to load unity or anything else. Literally just gets stuck on a desktop background.

Another update:

Following the 'Answer' marked below this, for both the catalyst 12.10 and 12.11 beta, the problems are still persistent:

Catalyst 12.10

It would appear that Catalyst 12.10 is consistent and can get me as far as the log in window. After logging in I get the desktop background but nothing else. From here I was able to load Terminal and run ps -ef | grep unity which confirms unity has not launched.

Catalyst 12.11

After attempting a few variations for installing this driver, it still passes the Ubuntu splash screen and then fails to progress any further. Shown in the image above.

Log files from xorg and sys (assuming it's ok to post links here from a file host)

If anyone would like to look at my log files to help you can get them from the links below:

Syslog: http://www.mediafire.com/?fd76x66tao81etr

Xorg.0.log: http://www.mediafire.com/?g07ycz6pteizbqi

  • Don't install Catalyst drivers. If you want to check how much you can get out of your card, install any game using OpenGl. It should run as decent as on Windows. Second: install gnome-mplayer to check if your movies run smoothly as Totem player doesn't work for me(no problem with 1080p, occasional slow downs, my card is Radeon HD 7290). If you can watch movies and play games, leave Catalyst driver alone. If you really want to play with Catalyst drivers, here's my story: askubuntu.com/questions/226396/… – Melon Jan 8 '13 at 11:07
  • Are you saying that I shouldn't need to install the catalyst drivers because the open source drivers should actually fully support all features of my graphics card already? I just need to test the card to confirm? – CTilley147 Jan 8 '13 at 11:59
  • The open-source drivers have very poor power management. As a laptop user you will want to try everything you can to get the proprietary drivers to work. There are power management tweaks for the open source driver, but they will only get you so far. – Glutanimate Jan 8 '13 at 13:13
  • Right so an update. I have managed to install the 12.10 driver from catalyst and when I reboot, I get the login screent etc. After I log in, it loads my desktop background, but it does not appear to load unity or anything else. Literally jsut gets stuck on a desktop background. – CTilley147 Jan 8 '13 at 15:10

I was not using the same graphics card, but I was able to install the BETA AMD drivers on 12.10.

Main Instructions

However, I had a few issues, so here were my modifications to the steps given in the 12.10 section.

  • Purge Items per instructions (from the 12.04 LTS section)
  • Install Dependencies (from the 12.04 LTS section)
    • MODIFY sudo apt-get install ia32-libs; those libs didn't exist. I went to the package manager and found ia32-libs-multiarch that are mentioned in the 64-bit section; I am 32bit. I didn't install from command line.
  • MODIFY, I didn't do the WGET or chmod on the 12.6 version shown in the steps, I went to AMD's site and downloaded the BETA drivers. (Follow link in the second COMMENT from "thelastshadow").
  • Ran commands to install/reboot.

Do everything in that second link, I rebooted with new drivers, then ran the script to uninstall the watermark. So, all the right steps are here and answered, just have to jumble them up a bit! BTW, the 12.6 and the 12.10 drivers DID NOT work for me. I had to uninstall them and follow the same steps with the beta drivers and they worked fine. I did the steps exactly as shown using the 12.6 with the wget and didn't have success.

Hope that helps!

  • I have pretty much followed your instructions and the instructions in the links you provided etc but that has gone back to now not booting correctly rather than failing to launch unity etc. So it appears catalyst 12.10 allows me to login can't go any furhter. Catalyst 12.11 (beta) forces it to go through starting and stopping processes but it is stopping at '*Starting CPU interrupts balancing daemon' and will not advance any further. I will try this again from a fresh install when I am back at home, as I am trying to juggle this alongside my work load at the moment. Will post results again. – CTilley147 Jan 8 '13 at 17:01
  • Anyone else able to assist further? – CTilley147 Jan 11 '13 at 0:02

Remove the existing drivers:

sudo apt-get remove fglrx fglrx-updates

....and try the latest beta driver 13.8


The solution for me on a ubuntu 13.10 was to install the 12.104 beta drivers

  • fglrx-amdcccle_12.104-0ubuntu1_amd64.deb

  • fglrx-dev_12.104-0ubuntu1_amd64.deb

  • fglrx_12.104-0ubuntu1_amd64.deb

The latest catalyst betas don't support the AMD Radeon HD 7640G anymore.


Not sure if the fglrx 13.101 will work, but 12.104 is still way faster than the ubuntu repos version for my asus k55n


I actually found out how to fix this problem

if you uninstalled fglrx to get your screen working again, then you need to reinstall it.. and then use the /usr/share/ati/amd-uninstall.sh script after reinstalling fglrx...

After you uninstall with the script you should be able to properly install a new driver.

Make sure you purge fglrx between using the script and installing a new driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.