I have a 2011 Macbook Pro, and when I'm typing my palms cover the upper corners of the touchpad, and frequently touch at the same time. It seems palm detection isn't working, or possibly a small enough portion of my palm touches the corner so that it registers as a finger. At any rate, I frequently get a two-finger scroll action occurring as a result of this, which can lead to some very annoying results while typing text.

It seems to me that a two-finger scroll should only be registered if the fingers are somewhat close together, not at opposite sides of the pad. Is there a setting for the synaptics driver that I can change this behavior?

I don't know about adjusting the two-finger-scrolling width, but you open "System Settings" and go to "Mouse and Touchpad" you can set it to turn the touchpad off when you type and adjust the sensitivity.

enter image description here

You could try xinput

First in a terminal type xinput list and note the id of your touchpad.

Then type xinput set-prop x "Synaptics Palm Detection" 1, where x is the id of your touchpad. This command will remain active until you log out.

If it is effective then open Startup Applications and add this command to the list.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.