I'm trying to set up a TFTP server using xinetd but I haven't had any luck so far. I have installed the following packages: xinetd, tftpd, tftp.

After that I changed the /etc/xinetd.d/tftp so that it would start the tftp automaticaly and even restarted the machine to see if it would work (yes, I'm that desperate...). It doesn't seem to get it working.

Then I tryed using the tftp command to get a file from another pc. Here is the thing, I can get something from another tftp server, but not from my localhost. The other machine can't fetch anything from mine either.

Oh, and I did a chmod 777 to both /tftpboot and the foo file I'm using in this test.

Anyone knows why am I the only being that can't use the tftp as it should? Just a last minute update, when I type "status" inside the tftp command I get this:

tftp> status
Not connected.
Mode: netascii Verbose: off Tracing: off
Rexmt-interval: 5 seconds, Max-timeout: 25 seconds

Thanks for the help!

closed as too localized by qbi, user25656, hhlp, user76204, Uri Herrera Mar 6 '13 at 0:39

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I solved this problem installing the atftpd package! – Davi S Evangelista Jan 7 '13 at 18:54

The OP reported that installing the atftpd Install atftpd package solved this problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.