I'm using Ubuntu 12.10 on my MSI X460DX notebook for a few weeks. Touchpad worked without problem. 2-finger scrolling worked as well as disabling touchpad with key shortcut. But now after a restart touchpad just stopped working completely. System Settings->Mouse and Touchpad->Touchpad tab was not here So I tried to run sudo modprobe psmouse and than it started working, but the touchpad settings still aren't here and neither edge scrolling nor 2-finger scrolling is working. I also can't disable it. I found out, that the touchpad is recognized as PS/2 Generic Mouse instead of my elantech touchpad.

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ A4TECH USB Device                         id=10   [slave  pointer  (2)]
⎜   ↳ A4TECH USB Device                         id=11   [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

Is there a way how can I get my touchpad working properly as before?

  • Check out this link: askubuntu.com/questions/109345/…
    – Mukund
    Jan 6, 2013 at 21:15
  • I tried everything I found there, but nothing worked, but thanks anyway.
    – jandurek
    Jan 11, 2013 at 18:45
  • Same issue on Kubuntu. Just restarted my Dell after 30+ days. 1. Touchpad does work, but tapping on it doesn't register as a click which it did before. 2. Trying to open the touchpad settings crashes the settings app.
    – Dror
    Jan 16, 2013 at 22:55

1 Answer 1


I found the solution! I found it here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/667707 and a workaround from comment #3 worked.

sudo rmmod psmouse
sudo insmod /lib/modules/`uname -r`/kernel/drivers/input/mouse/psmouse.ko

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.