Okay, before you ask me to RTFM, I'll show you a screenshot, and describe my situation:



This is what I want to get. The screenshot above shows (semitransparent) Conky, but the transparency is provided by adding an opacity filter for Conky in ccsm. Needless to say, that only works when the window is controlled by the WM, ie. when Conky is in normal mode (and not desktop or override). This is kinda okay, but if you click the "Show/Hide All Windows" button, Conky gets hidden as well (which ideally, should not happen.

Conky Configuration File

alignment top_right
background yes
use_xft yes
xftalpha 0.1
border_margin 5
border_width 5
default_color white     # grey 5f5f5f 3F3F3F
double_buffer yes
draw_borders no
draw_outline no
draw_shades no
gap_x 30
gap_y 60
maximum_width 240
minimum_size 175
no_buffers yes
override_utf8_locale yes
own_window yes
own_window_title conky
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_transparent yes
own_window_type override    ## normal /override /desktop
text_buffer_size 200
total_run_times 0
update_interval 1
uppercase no
xftfont Ubuntu Beta:size=8

#               fonts
#   Blue Highway
#   Zegoe Light - U
#   Zekton
#   Calibri
#   Engebrechtre
#   Opeln2001
#       Aller Display

${font Aller:pixelsize=55}${alignc}${time %H:%M}${font}

${font Aller:pixelsize=11}${alignc}${time  %B %d, %Y}
${alignc}${time %A}${font}

#${voffset 10}${alignc}${font StyleBats:size=8}A${font} CPU1: ${cpubar cpu1 9,80}
#${alignc}${font StyleBats:size=8}A${font} CPU2: ${cpubar cpu2 9,80}
#${alignc}${font StyleBats:size=8}g${font} RAM:  ${offset 1}${membar 9, 80}
#${font Webdings:size=10}~$ ${battery_bar}

...and more

I've used every possible combination of argb settings and stuff, but nothing works. I really want it to be:

  1. Semitransparent
  2. "Sticky", so that it isn't minimized when you use C-D or "Hide All Windows"
  • 3
    We don't give an RTFM or LMGTFY at Ask Ubuntu. :)
    – Sid
    Jan 28 '11 at 11:03
  • Sid: ;). On a side note, when I was trying to configure compiz to enable the fake-transparency, I accidentally made all windows 100% transparent. Fixing that was fun :)
    – aviraldg
    Jan 28 '11 at 11:37

To enable compositing, i.e., true transparency not just pseudo-transparency, you have to enable ARGB:

own_window yes
own_window_type normal
own_window_class conky-semi
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_transparent yes
own_window_argb_visual yes
own_window_argb_value 128

If you want a semi-transparent black background, just set own_window_transparent no

To control the transparency level, play with own_window_argb_value, ranging from 0 to 255.

Source: http://crunchbanglinux.org/forums/topic/13231/solved-compositing-and-conky-wierdness/

  • i love how own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager lets you create a window like desktop but without all the glitchiness Jun 22 '18 at 22:03

This worked for me:

own_window yes
own_window_title conky
own_window_type normal
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

Then go to the compiz setting (CCSM), enable "opacity, brightness and whatever", click on the leftmost "opacity" tab. Let Alt Button4 and Alt Button5 control the opacity/transparency setting.

After that just mouse-over conky and let the Alt button rock & roll.

  • 1
    This worked for me with the additional step of going into CompizConfig Settings Manager under General Options and unchecking "Hide Skip Taskbar Windows". This keeps conky from disappearing off the desktop. Apr 18 '11 at 15:35
  • One more thing: to get rid of the shadows for conky, I had to put !name=Conky in "Shadow windows" of "Window Decoration" in CompizConfig Settings Manager. Apr 18 '11 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.