6

I have two Linux machines one at work and one at home they are identical hardware and the setup it pretty much the same. Both run Ubuntu 12.04 LTS and gnome-shell 3.4.1

One difference is that to connect to internet at work i have to use the proxy server.

Eveything works well except for gnome extensions. For some reason i'm unable to install extensions from http://extensions.gnome.org at work. The switch on the page flicks and prompts about the installation but doesn't do anything after that.

Nothing gets added to ~/.local/share/gnome-shell/extensions/ folder or the /usr/share/gnome-shell/extensions folder and also nothing shows up in the gnome-tweak-tool. Also the flick switch returns to original position after the page is refreshed.

I assume that something (probably gnome-shell) doesn't read the $http_proxy and $https_proxy environment variables and tries to download the files directly, Because at home where i don't have proxy everything works fine.

So the question is: Does gnome-shell use the system-wide proxy settings when installing extensions. If not How can i force it to do so (some nifty hack or smth)?

hertz@hertzbox:~$ uname -a
Linux hertzbox 3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5 17:42:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

hertz@hertzbox:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.1 LTS
Release:    12.04
Codename:   precise

hertz@hertzbox:~$ gnome-shell --version
GNOME Shell 3.4.1

~ George

2
  • Can you set a systemwide proxy like in this answer and try again?
    – qbi
    Feb 12, 2013 at 11:55
  • http_proxy & https_proxy environment variables are set correctly all other applications (like wget, apt-get, chrome and etc..) are working correctly through proxy. Its just the gnome shell that ignores that.
    – George
    Feb 16, 2013 at 14:07

1 Answer 1

3

Gnome has it own set of variables where you can configure the proxy. You can read up on a few places where you need to configure the proxy here.

Your specific problem should be corrected, using this code in a shell:

gsettings set org.gnome.system.proxy mode 'manual'
gsettings set org.gnome.system.proxy.http host 'yourproxy'
gsettings set org.gnome.system.proxy.http port 8080
gsettings set org.gnome.system.proxy.ftp host 'yourproxy'
gsettings set org.gnome.system.proxy.ftp port 8080
gsettings set org.gnome.system.proxy.https host 'yourproxy'
gsettings set org.gnome.system.proxy.https port 8080
gsettings set org.gnome.system.proxy ignore-hosts "['localhost', '127.0.0.0/8', '*.localdomain.com' ]"
4
  • 1
    Any idea why it doesn't work with PAC file?
    – cprn
    Feb 25, 2014 at 10:54
  • 1
    the gsettings only works when setting your proxy manual. A pac file is a -more or less- automatic proxy setting. Try something in the lines of the following command: gconftool-2 --set /system/proxy/autoconfig_url --type string ${auto_proxy} or use the GUI, that is also an option ;-) If it doesn't work right like you want it, try to Google a bit. It is the best way to learn stuff...
    – phulstaert
    Mar 14, 2014 at 15:45
  • Install dconf-editor for a nice easy way to configure and test settings via gnome. The structure mimics that shown in the above answer so once installed, just open and click through the heirarchy to get to the desired setting and apply the appropriate value
    – Pancho
    Feb 6, 2016 at 12:10
  • Thank you for this answer. I would like to add that it seems like gnome extensions also use those proxy settings, if they need an internet connection. For example, I installed the extension "Bing Wallpaper", and wanted to pull from a locale that's unavailable in my region. After setting gnome's proxies with your answer I was able to bypass said restriction via my personal proxy server.
    – cyqsimon
    Apr 15, 2021 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.