My flash disk is password protected. When I plugged it into my Ubuntu machine I didn't see the flash disk appear, but when I plugged it into Windows I can see the drive but can't open the drive. It gives me the option to "format" but when I click on "format" it says "password protected".

Is there a way to format my drive and back to the original?


I don't have any experience with password protected flash drives but most probably password protection is a software feature and not the hardware one. If that is the case then you can run gparted on ubuntu and delete the current partition(s) on your flash, then recreate a partition(s) and format it to your desired file system.

To install gparted use:

sudo apt-get install gparted

you can then run it System->Administration->gparted


Your disk may be failing, try running

sudo badblocks -v /dev/sdb 

if the ouput from this command says zero bad blocks then try write mode test to make sure that your disk is fine. Use

sudo badblocks -v -w /dev/sdb

for write mode test.

  • thank you, i tried that but gparted unable to format the partition error massage: "input/output error during write on /dev/sdb error fsyncing/closing/dev/sdb:input/output error" – Achu Jan 28 '11 at 9:17
  • Your disk may be failing, try running "sudo badblocks -v /dev/sdb" – binW Jan 28 '11 at 9:23
  • When i run that command it says "checking for bad blocks (read-only test)" after that i tested again gparted. but same problem. – Achu Jan 28 '11 at 9:52
  • did u let it complete? I mean it should give some output – binW Jan 28 '11 at 10:08
  • 1
    the output of badblocks is the list of badblocks. So non stop number output means most of the disk is not usable meaning you need a new disk. – binW Jan 28 '11 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.