When I plug my canon 500d camera into the usb port of my ubuntu pc it shows the camera in the files, and I can see the images on the camera, but if I try to copy any of them to the pc, nothing happens, the progress bar stays at 0 and never gets any further.

I have installed gphoto2 as someone suggested, but now I dont know what to do, I cant find any icon for it and the camera still behaves the same.

I have installed gtkam as someone suggested too, but again it still behaves the same. I got the gtkam software to run at the command line, but when this happens I can detect the camera, but when I say 'apply' or 'save', I get an error saying it cannot mount.

All I want to do is copy files from the camera to the pc

any suggestions?

  • 1
    If you use gtkam or a comparable tool, you should first unmount the camera in nautilus (right click/eject) and only then start gtkam so the program can find and mount the camera itself. Can you try this? – don.joey Jan 5 '13 at 10:57
  • 1
    Some cameras have a setting (usb storage or similar) that you can select, so that it appears as a regular usb drive, rather than a camera when you connect to any PC. This does work with a friend's Nikon D70 on Ubuntu. Alternatively, you could just take the memory card out and put it in a card reader; that is often the simplest way. See my answers here and here. – user76204 Jan 6 '13 at 1:38
  • 1
    Can you confirm that one of the above solutions did the trick? If so, Mik or I will post it as an answer. If not, did you get it to work? – don.joey Jan 24 '13 at 14:36


This worked well for all cameras for which I tried:

Take the memory card out of the camera and read it from a card reader.

Connecting the camera directly, this supplied the same result for several past cameras. It does not work this simple way for example on the recent CANON IXUS 310 - and for many others.

In this case something like the following can help.


unconnect the comera from the computer and close all photo viewing software.


From the offered options choose: "Create Folder". Now the thumbnails should be displayed.

This way you can state the folder names on the memory card (if you did not know them), Example: Images are on the card like: DCIM/114_*/*.jpg

LOCATE THE DIRECTORY in the primitive SOS manner:

ls /run/*/*/*/*/*DCIM*/114_*/*

  • If no success, try by increasing or decreasing the number of: /*

  • (If using /* instead of /run --- then it may take minutes but is a more general method for the case that it does not work)

You should now see something like:




something like this should work, too:

ls /run/user/piotr/gvfs/*/DCIM/114_*/*JPG


copy from the camera to the PC

cd /run/user/pedro/gvfs/gphoto2:host=%5Busb%3A001%2C019%5D/DCIM/114*

will also work. But I would avoid to walk this way inside the card or to do a remove of its files or to do a mv from the card.

I am not sure how locks, integrity and so on will be managed by the camera properly. Normally it should not cause problems. But CANON - like others - asks to format cards only within the camera. So there might be specifics involved and the standardization of memory cards goes not down into the details. In fact on CANON forums problems were communicated which were resolved when reformatting the card inside the camera.


The is the risk that only 10 images or so may be copied - and then copying stalls. - About this:

Copying photos from camera stalls - how to track down issue?

See there:

"The bug mdr mentions in his comment (https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1075923) is now fixed, and a gvfs update that fixes the problem was pushed out on 2013-10-03 (http://launchpad.net/ubuntu/+source/gvfs/1.16.1-0ubuntu1.1). So all you need to do at this point to fix this problem is update your ubuntu gvfs package."

As long as it could not yet tested on your PC:


Connect the camera via USB and opt for: Shotwell

In Shotwell : In Preferences: Define the directory wanted for imports. Then import the images. They will be there.

So this is a way if you do not want to change too often the memory card, as long as other better ways via the terminal window do not work.

"QUICK AND DIRTY, but it did the job"

There might be more intelligent solutions. I am surely not a systems software expert... But it does the job, and this might be helpful as long as there are no more intelligent answers here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.