The last time I ran sudo apt-get upgrade ess gave this error and now says its not fully installed. I checked and installed all dependencies and couldn't find any other reports of this issue. I also tried completely removing and re-installing ess with no luck.

enabling speedbar support
[ess-r-d:] (autoload ..) & (def** ..)
Wrong number of arguments: define-obsolete-function-alias, 3
xemacs exiting
emacs-package-install: /usr/lib/emacsen-common/packages/install/ess xemacs21 emacs23 xemacs21 failed at /usr/lib/emacsen-common/emacs-package-install line 30, <TSORT> line 1.
dpkg: error processing ess (--configure):
 subprocess installed post-installation script returned error exit status 255
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • and this problem is back with the new update to ess – sayhey69 May 18 '13 at 1:11
  • 2
    This just happened to me. Proposed solution below doesn't work. Any updates since? – ilya May 18 '13 at 22:50

The problem seemed to return. So I reinstalled both ess and emacs and that seemed to work:

sudo apt-get purge ess
sudo apt-get purge emacs
sudo apt-get install emacs
sudo apt-get install ess

Previous fix

sudo dpkg -r ess 
sudo apt-get check 
sudo apt-get update 
sudo apt-get upgrade --fix-missing 
sudo apt-get install ess

Do you have emacs21 installed? Then you'd better go to 22 or 23. Seems like this causes these problems.

If you have multiple emacs installed, it might also be best to remove them.

  • no I had emacs23 installed. After that I tried installing emacs24 (after removing 23), I still get this problem. I will try installing it manually. – ilya May 22 '13 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.