13

I try to run thinkfan.
I installed it and configured it.
But if i do this i get an error.

chris@chris-ThinkPad-T410:~$ sudo thinkfan -n

WARNING: Using default temperature inputs in /proc/acpi/ibm/thermal.
Config as read from /etc/thinkfan.conf:
Fan level   Low High
 0      0   42
 1      40  47
 2      45  52
 3      50  57
 4      55  62
 5      60  67
 6      65  72
 7      70  77
 127        75  32767
Module thinkpad_acpi doesn't seem to support fan_control

How to solve this?

1
3

I was using the instructions here: http://x220.mcdonnelltech.com/ubuntu/ and was thus missing the driver option expermental=1 in my /etc/modprobe.d/thinkfan.conf file - which seems to be needed to get this working as expected.

Do the following:

sudo nano /etc/modprobe.d/thinkfan.conf

There should be a line

options thinkpad_acpi fan_control=1

change it to

options thinkpad_acpi experimental=1 fan_control=1

Reboot your computer so the changes take effect.

2
3

first be sure the fan is enabled, as a default, its not :

echo "options thinkpad_acpi experimental=1 fan_control=1" >/etc/modprobe.d/thinkpad_acpi.conf

relaunch the module :

sudo rmmod thinkpad_acpi ; sudo modprobe thinkpad_acpi

then edit the thinkfan config file

vi /etc/thinkfan.conf

mine is setup like that :

 tp_fan /proc/acpi/ibm/fan 

 tp_thermal /proc/acpi/ibm/thermal (0, 10, 15, 2, 10, 5, 0, 3, 0, 3)
 
 (0,    0,  41)
 (1,    40, 51)
 (2,    50, 56)
 (3,    55, 61)
 (4,    60, 65)
 (5,    64, 68)
 (7,    67, 32767)

the numbers are the temperature levels, for example > (5, 64, 68) means fan level 5 between 64 and 68 degrees

level 7, the maximum, above 67 degrees

service thinkfan restart

and check the messages with :

journalctl -f

1

Not a direct answer but you might want to have a look at http://www.thinkwiki.org/wiki/Fan_control_scripts. That place is always an excellent source for Thinkpad problems.

1
  • 1
    Those informations are outdated, i have Ubuntu 14.04 and i have no file /etc/modprobe.d/thinkfan.conf. I'm stuck at that step. – Youda008 May 15 '17 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.