I am running Ubuntu as a server, but with X-windows setup. I have SSH , Samba and RAID 5 setup. Was having trouble browsing Samba shares from my Windows 7 laptop, so I thought it might be a problem with the version of Samba and started installing Samba4.

Well, Samba4 was whole another bucket worms. I managed to get the install process to partially finish. After being frustrated I rolled back and reinstalled Samba3.

Ate this point I tried to create a SSH session with my user freak_storm and the password did not work. so, I went to the box and tried loxing through the X interface. No luck. I tried another user and it logged in. I tried changing freak_storm's password with 'su passwd freak_storm' ,but it just returns a command prompt. So I tried with the current user 'passwd' and it asked for current password and command prompt. I logged out and logged back in and now that user is broken.

So, I logged through the recovery panel and dropped down to root.
1) check password file and it's not corrupt 2) Re-installed the passwd package 3) deleted and re-installed passwd package. 4) removed Samba3 and re-installed

I'm now stuck. I really don't know where to go from here?

any suggestions? Should I do a fresh install?

  • 1
    Could you add the output of grep freak_storm /etc/passwd? Delete any (hashed) password strings before putting them here into the public! – lumbric Jan 4 '13 at 14:39

You need to first use passwd [username].

Then you need to do smbpasswd -a [username] for a new user. Otherwise just use smbpasswd [username].

Make sure both passwords are same.


su freak_storm passwd and su -u freak_storm passwd are two different things.

The -u option runs passwd as the freak_storm user (which is what you want, I think).

  • I tried some of these solutions and some others. Finally gave up and just re-installed. It really bothers me to re-install, but sometimes bebuging can become,so frustrating I have to give up. Having said that, I have a way better understanding of the how passwords are stored in Linux. – Clay Jan 13 '13 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.