I'd like to first apologize for my lack of detail in the information as I'm new to Linux and I'd be happy to provide more if you point me in the right direction.

I've tried both 12.04 and 12.10 and both have had issues booting.

In 12.04 I couldn't reboot. A reboot would cause a hang and after the system hanging repeated times, it would start working again. When I would boot up in "regular mode", it would hang at a purple screen. I then tried recover mode which would hang at "fb: conflicting fb hw usage inteldrmfb vs EFI VGA - removing generic driver". I found an article recommending removing "gfxmode $linux_gfx_mode" from the normal boot entry but it wasn't present. Then I removed the quiet splash from the normal boot and found that after "usb 1-1.4: new full-speed USB device number 4 using ehci_hcd" the system would hang. Then I would get "INFO: task swapper/0:1 blocked for more than 120 seconds" with some hex details and a verbose output.

I was advised to upgrade to 12.10 to avoid any potential issues although I wanted to run 12.04 for the LTS side of things. I did a full fresh install of 12.10 and not an upgrade. With 12.10, I have rebooted a few times without issue. I then tried to perform a shutdown which seemed fine until I tried to boot back up and again found I was having issues. The only difference I've found in 12.10 is that now it hangs after the following:

usb 1-1.4: new full-speed USB device number 4 using ehci_hcd usb 1-1.4: New USB device found, idVendor=0489, idProduct=e042 usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3 usb 1-1.4: Product: BCM20702A0 usb 1-1.4: Manufacturer: Broadcom Corp

And then in hangs again at task swapper.

For HW this is a new Lenovo Z480 and any help you could provide would be well appreciated. Thanks!


Okay I just ran into the same problem on my Z580 with Ubuntu 12.04. It rebooted fine a couple of times and then hung up on the purple screen. I had to force restart it again, and now it only shows a blinking cursor. Choosing the recovery boot option hangs up at the exact same place you described.

After some googling it seems like this is a common problem on Z580's recently, and it appears it has something to do with the UEFI boot. Look at the following two threads. Unfortunately, there is no solid solution yet.

Hope this info will help someone more knowledgeable to come up with a solution.


I managed to solve this issue by booting into the previous Linux kernel 3.2.0-29-generic(the one that came with the 12.04 install disk). To boot using a previous kernel choose "previous linux versions" from the grub boot menu.I later noticed that the problem indeed occur after a kernel update to 3.2.0-35-generric. So it still doesn't boot into the new kernel and hangs as described in the original question. So there for I believe this has something to do with the new 3.2.0-35- kernel.

  • Thanks for the tip, but I haven't had the same success with different kernels. I've now realized that it's hanging just before mounting the drive. Because of this, I'm unable to gather any logs it seems. – Derek Mar 18 '13 at 4:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.