When I start nvidia-settings it gives me:

You do not appear to be using NVIDIA X driver. Please edit you X configuration file (just run nvidia-xconfig as root), and restart the X server.

Also, there are no settings available in this window.

When I ran nvidia-xconfig (as sudo), it generates this file:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.40  (buildmeister@swio-display-x86-rhel47-06.nvidia.com)  Thu Apr  5 22:40:54 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"
    FontPath        "unix/:7100"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Then I reboot the system, and the only resolution available is somethink like 640x480 (far away from native 1600x900). If I restart X only the systems logs me out (login screen), gives crappy resolution and whenever I log on, it immediately logs me out again. To solve this, I installed gdm and reconfigured it. I have a different login-screen now, which is not the main problem.

(I surely deleted xorg.conf and rebooted to get my resolution back everytime it was fu**ed up)

Additional Drivers says: nvidia_current, with a note beneath it: This driver is activated but not currently in use.

System Settings > System > Details > Graphics says: Driver: Unknown, Experience: Standard

I use ubuntu 12.04.1 LTS Graphics card: GeForce GT540M Cuda (tm) 1GB

I have tried to solve the problem every now and then and I get really frustrated with it. For not being able to play games with high settings, not being able to run an external Monitor (HDMI, TV) with a resolution higher than 5XX x 7XX and so on.

Need any more information?

Thanks in advance.

Additional information:

Output of lspci | grep VGA is

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1)
  • What is the output of lspci | grep VGA? – Salem Jan 3 '13 at 21:53
  • Did you ever get this fixed, Sven? I have the exact same problem with the exact same card. – KenB Apr 17 '13 at 23:42

Are you really sure you deleted /etc/X11/xorg.conf? Without it the system should be back to normal... Either way there's this post that suggests running this command to reconfigure Xorg:

sudo dpkg-reconfigure -phigh xserver-xorg

Also you should remove the nVidia driver. Your system seems to have Optimus technology, so you can't install the nVidia driver the same way you would in a normal system. If it was installed through apt-get/Software Center this should remove it:

sudo apt-get remove nvidia-current

If you want to disable your nVidia card (to save some power) and use it to run some specific programs (like games) you should try Bumblebee. You can find more info on how to install it/debug problems on Ubuntu Wiki or here at AskUbuntu.

Hope this helps.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.