I have Nvidia problems I don't know what happen because when I run WarCraft with optirun it display errors then if I type optirun glxgears, it displays the same errors as when im running warcraft ..

optirun glxgears
[   25.424416] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[   25.424460] [ERROR]Could not connect to bumblebee daemon - is it running?

How to fix this?

PC specs: Ubuntu 12.04 64 bit with a NVIDIA GeForce GT 630M

I used lspci | grep VGA which gave me:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller(rev 09)

It seems my laptop does not detect my Nvidia GeForce GT 630M anymore. It worked before I knew that my optirun is broken, I didn't do anything.

I just installed Geany recently and make a virtual host and oh yes, i use ctrl + alt + sys req + REIUSB because I had my laptop freeze few hours ago

Please if anyone can help i will really appreciate it.

I have already posted my solution as an answer below.

Note: I already had Bumblebee installed. It worked before, but all of a sudden my laptop suddenly doesn't recognize my VGA..

New questions

  1. Why did my initial problem arise? Is it because I used ctrl + alt + sys req + REIUSB ?? Yes i typed it REIUSB and not REISUB..
  2. Why did my solution work?

I already searched in google and didnt find any good/clear answer(the answers too hard for newbie to understand) please answer with details because im a newbie in ubuntu and also in computer .. i just installed ubuntu 2 weeks ago so i can learn about computer.

  • It think you are using a Optimus compatible VGA (A computer with an Intel and a NVidia VGA Card) Optimus switchs between that two VGAs when you play games and programs with high need of Graphical process . Bumblebee is a free and Open-source implementation of Optimus technology , It think you should download and install it . – Mahyar Pasarzangene Jan 3 '13 at 19:15


what i have done : i frustrated, i boot ubuntu live cd and try ubuntu, use lspci | grep VGA

it detected my 2 vga:

00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0de9 (rev a1)

i slept, then i woke up in the morning, hope for magic happens, AND YES IT DOES, use optirun and it works! it also detected my VGA with lspci | grep VGA

note: i already had bumblebee installed and it worked before my laptop suddenly didnt recognize my vga..

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.