Good day. i have a problem. i have been running ubuntu 12.04 on my asus n76v. with nvidia geforce gt 650m 2gb graphics card for two weeks. yesterday while trying to get my accelerated graphics to work i installed the experimental drivers 310 from synaptic. after which my display went from 1280x whatever it is, to 640x480. i followed Desktop does not show when I installed nvidia drivers!. and Cannot install Nvidia drivers. and Ubuntu 12.04 Nvidia drivers. to no avail. then i did a fresh install. it worked until i did the updates. after the updates it went back to 640x480. not sure if i am missing something, or just screwed, i just know it worked for two weeks with no problems and now i cant fix the resolution.


Nvidia cards use their own display settings when you install the proprietary drivers. Try changing the resolution in the Nvidia Settings Manager by opening the Unity dash and typing in "nvidia". The Settings Manager should be the first thing that comes up.

From there, go to "X Server Display Settings" and change the resolution to your screen's native resolution, then click "Apply" to test it. Your screen will flicker and bounce a little as everything adjusts, but if all goes well, you should have your desktop at the proper resolution. Make sure to confirm that setting in the dialog that pops up, so that it doesn't revert automatically.

Finally, click "Write to configuration" to make the changes permanent. It will likely prompt you for your password, since writing to the video config requires sudo.

  • Any sources on: "Nvidia cards use their own display manager". As far as I know this isn't even remotely true. – Javier Rivera Jan 3 '13 at 16:03
  • 1
    @JavierRivera - Not display manager as in X, but display manager as in settings manager. IE - Instead of using Settings -> Display to change your resolution, you use the Nvidia Settings Manager. Until 12.10, Settings->Display didn't even pick up resolutions when the Nvidia proprietary drivers are active. – Shauna Jan 3 '13 at 18:56
  • Yes, that makes more sense :). – Javier Rivera Jan 3 '13 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.