47

A while back, I set my default file manager to Nemo. I like it a lot, but it constantly crashes. I remember editing a text file to set it as default, but I forgot which file it was. How do I switch back to the Nautilus file manager?

2

5 Answers 5

50

This did it for me, after I google for a while:

xdg-mime default nautilus.desktop inode/directory application/x-gnome-saved-search

I also typed:

gsettings set org.gnome.desktop.background show-desktop-icons true
3
  • After that my Linux Mint failed to log in with X-session error g_key_file_free: assertion 'key_file != NULL' failed. To recover use Ctrl-Alt-F1 & sudo apt-get cinnamon and sudo reboot
    – Zon
    Jul 18, 2018 at 4:26
  • The xdg-mime command worked for me in Ubuntu 16.04. I replaced nautilus.desktop with pcmanfm.desktop since I wanted to use that as my default file manager. You can find the name of the file manager you want to use by using the following command ls /usr/share/applications and finding its corresponding .desktop file.
    – OwN
    Jun 19, 2019 at 3:08
  • 5/5/20, it works on Ubuntu 19.10 May 5, 2020 at 7:36
21

I spent AGES trying to find a method that would work. Eventually I found this advice, which is incredibly easy, and worked for me:

Install exo-utils (this package contains the Xfce settings plugin and the utility files for libexo-2-0). Open a terminal and type:

sudo apt install exo-utils

Then run:

exo-preferred-applications

then switch to Utilities tab and select File Manager you prefer.

8
  • It'll only work in Xubuntu or systems that have exo-utils installed
    – Anwar
    Apr 7, 2017 at 12:26
  • 1
    Is there any reason not to install exo-utils? (I use Ubuntu 16.04 and this method of changing the File Manager back to Nautilus, from Nemo, was the only method that worked, out of several I tried.)
    – user282186
    Apr 8, 2017 at 12:42
  • Worked well for krusader after I installed it
    – loxaxs
    May 15, 2017 at 9:37
  • 1
    This is the only way I could make xdg-open open directories with nautilus in Debian, thanks.
    – jojman
    May 24, 2017 at 5:40
  • 1
    Worked great for me at Ubuntu 18.04.1 LTS!
    – ChrisG
    Sep 13, 2018 at 13:55
3

The file manager choice is handled by a file in ~/.local/share/applications. They are mimeapps.list and mimeinfo.cache, deleting both of those files will reset your file manager to the default, which is Nautilus.

1
  • 1
    I'm afraid that solution didn't work.
    – nick
    Jan 4, 2013 at 14:12
1
  1. sudo mv /usr/bin/nemo /usr/bin/nemo.backup
  2. Open any folder. You could use xdg-open /path/to/folder/ while in the command line, for example. Or you could use a X application that requests a file.
  3. A dialog should appear to you requesting a default application to be your file manager. Type /usr/bin/nautilus there and confirm.

After that, as long as you don't rename nemo to its original name/location, nautilus will be your default file manager again.

0

The answers here didn't work for me on Debian Bookworm - so after figuring it out myself:

Premise

Every time I attempt to leverage xdg-open on a directory (typically through an application; like Keybase's "open in file explorer" option, or something similar in Steam), what opens is Visual Studio Code.

What doesnt work

Attempting to "Open with other application" a directory via the context menu in "Files" [Nautilus] (file explorer when using Gnome on Debian) and then "Forget association" on Visual Studio Code (right click on it in the list of applications), subsequently choosing "Files" to open the directory with - does not fix what is used for directories when xdg-open is invoked; it only changes what opens a directory from within "Files" [Nautilus].

What does work

Run the following:

xdg-mime default org.gnome.Nautilus.desktop inode/directory

The standard, as explained, is as follows:

  1. xdg-mime default
    • We're setting a default application
  2. org.gnome.Nautilus.desktop
    • We're setting the default application to be Nautilus, by its fully-qualified desktop menu name; It's registered as org.gnome.Nautilus.desktop.
  3. inode/directory
    • For the mimetype inode/directory (found using xdg-mime query filetype /path/to/target, with target in my case being a directory.)

The accepted answer results in Nautilus.desktop and application/x-gnome-saved-search becoming the default application(s); which is not correct, it must needs be org.gnome.Nautilus.desktop.

Also, setting desktop icons to be shown won't set the default application when opening directories via xdg-open.

Alternatively, you can also set it as follows:

nano ~/.config/mimeapps.list

Scroll down to inode/directory under [Added Associations], as well under [Default Applications], and ensure that the line(s) read:

inode/directory=org.gnome.Nautilus.desktop

You can additionally add, under [Removed Associations]:

inode/directory=code.desktop;

This is just the manual, longer, way of doing what I suggested first - together with the "Forget association" bit I portrayed I had attempted

2
  • 1
    This has got to be the oldest thread I’ve seen revived, 7 years later
    – nick
    Aug 30 at 13:48
  • @nick It's a good question because it can stump people who've used Debian/Ubuntu for even longer; and 7 years later the answer(s) can/will change. You should never hesitate to answer a question regardless of its age; especially if the question exists already - and the historic answer doesn't work any longer. People are encouraged not to repeat questions; stack has evolved its products so that answers may stack according to most recent upvotes (recent preference changes, you may have noticed). In a sense revival isn't really a thing, because ongoing support is supported/expected.
    – Rik
    Aug 31 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.