14

I'm running Ubuntu in VirtualBox on my Macbook Pro.

I chose a 'French (Mac)' layout (see below). enter image description here

Unfortunately, the character | (vertical bar) does not seem to be mapped! Usually, in Mac OSX, I get it by pressing: [alt]+[shift]+L.

How can I add a vertical bar (any key combination would be ok) to this keyboard?

  • This Mac keyboard layout has 3 major flaws: [return] • doesn't permit to type correct French, ex. missing: É, È, Ù… [return] • doesn't permit to type Unix commands, missing: \, | [return] • many of the key mapping are too cumbersome to be memorized. – dan Aug 24 '17 at 14:51
  • @danielAzuelos É is not missing : first, press down the Caps Lock key and then press any other letter key to have it capitalized (including accentuated ones). For \ and | just press Alt+Shift+/ and Alt+Shift+L respectively. – Hadrien TOMA Oct 13 '17 at 9:46
9

Here is my "commandline solution" (Ubuntu 12.04 server on MacBookPro 10.9 within VirtualBox 4.3.8) :

sudo apt-get install keyboard-configuration
sudo dpkg-reconfigure keyboard-configuration

Keyboard-configuration choices for MackBookPro French keyboard:

-> MacBook / MacBookPro (Intl)

-> French

-> French (again)

-> Right Alt (AltGr)

-> No Compose Key

It seems keyboard settings works fine and are keep after reboot.

--- EDIT Thomas ---

You should install all the console tools to make it work

apt-get install console-data

apt-get install console-setup

apt-get install console-locales

apt-get install keyboard-configuration
  • This solution works perfectly on VirtualBox, but with a fresh install on VMWare it did not match perfectly my layout: the "-" key for example types "§" – Louis 'LYRO' Dupont Apr 10 at 11:44
0

I'll post the solution for VMWare, since this topic comes first when searching for it on Google:

As Pascal said, launch the following commands:

sudo apt-get install keyboard-configuration
sudo dpkg-reconfigure keyboard-configuration

and select the following option in the opened interface:

-> MacBook / MacBookPro (Intl)

-> French

-> French (again)

-> Right Alt (AltGr)

-> No Compose Key

Once it is done, go in your VMWare preferences, then Mouse and Keyboard, and disable Keyboard mapping for languages. This should do the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.