I installed the latest version of x64 lubuntu and I want to install a scheme interpreter. Strangely, in Synaptic, only the debugger and documentation is available to install.

I would rather not compile my own version because this would be hard to maintain in the future.

How do I resolve this problem?

mike@ubuntu:~/Desktop/aplan$ sudo apt-get install mit-scheme
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mit-scheme:i386 : Depends: libmhash2:i386 but it is not going to be installed
                   Recommends: mime-support:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.
  • 3
    This is a bug in the mit-scheme package: Launchpad Bug #373018 – gertvdijk Jan 16 '13 at 21:48
  • @gertvdijk thanks for clearing this up. At the end of the day I went with guile, which works off the bat. You should post this as a answer so I can upvote it and we can have a resolution to this question. – Mikhail Jan 17 '13 at 0:29
  • Nope, questions about bugs are off-topic here. The common thing we do here is to avoid answers to bug-related questions and get them closed to have people report stuff in the relevant bug reports. So, don't forget to mark yourself as affected there! :) – gertvdijk Jan 17 '13 at 0:46
  • 2
    This is not a question about a bug. This is a question about simply having a problem installing a particular package from the package manager. Even if the problem exists because of a bug, it is still not a question about a bug. This question should not have been closed. – orb Nov 3 '14 at 21:47

You need to enable the installation of i386 packages on your amd64 system.

To do so, enter the following commands:

dpkg --add-architecture i386
apt-get update
sudo apt-get install ia32-libs
apt-get update
sudo apt-get install libmhash2:i386 mit-scheme:i386

For further information see the Debian Multiarch Wiki.


  • Multi-arch works in 11.10+ of Ubuntu. And then you don't need ia32-libs because of that. And I think it's not his problem as his package management is aware of the i386 packages. This makes your edit to the question also invalid as it suggests a cause which is probably not the case. – gertvdijk Jan 16 '13 at 21:02
  • I looked in launchpad and this commands worked for another user. What command you say that is not useful? Or what should to do the OP? – Lucio Jan 16 '13 at 21:29
  • 1
    Installing ia32-libs on a Multiarch enabled system is pretty useless, as you can see from the link. It's a bug as commented now to the question. While theoretically it would be possible to install this 32-bit build, some of the dependencies aren't available as Multiarch packages, so that's why apt-get bails out. Your solution: 0 upgraded, 24 newly installed, 217 to remove and 0 not upgraded. – gertvdijk Jan 16 '13 at 21:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.