I am fairly new to ubuntu so a step by step answer would be appreciated. My wireless card is Broadcom BCM4331. Thank You.

I also have no way to connect to the Internet on it except my original osx partion. So a solution that works offline is required. My Mac mini is a 6,1 model.


3 Answers 3


I ran into the same problem as you. I solved it by following the instructions on the help pages. The [instructions if you have wired internet] are the easiest - it will most probably be something like:

sudo apt-get install firmware-b43-installer

and after a reboot you'll be good to go.

I, however, didn't have a wired connection at hand (seems my ethernet is not working) and I had to follow the no-internet instructions. Basically, I first got the .deb files on another computer where I had internet:

  • b43-fwcutter
  • firmware-b43-installer

You have to search the packages portal under your Ubuntu version. You can install them with:

sudo dpkg -i b43-fwcutter*
sudo dpkg -i firmware-b43-installer*

Now, the second one will fail, as it tries to download the latest firmware from the internet. We can copy the link that it wanted to fetch, however, and make understanding our hardware specifics and finding the appropriate version that much easier. For me the url was:


You can then get that file, copy it to the problematic machine, extract it:

tar xfvj broadcom-wl-*

and install it manually with something like:

sudo b43-fwcutter -w /lib/firmware broadcom-wl-5.100.138/linux/wl_apsta.o

(the exact details, file name, driver version, will probably differ, and you should conclude for yourself based on the help page and some common sense).

A reboot was then enough for my driver to start working, but there is some talk of potentially having to blacklist other drivers - explore this if it still doesn't work for you.

  • Can confirm that this works on late-2012 Mac Mini with Ubuntu 18.04 LTS. Network sharing from wifi to ethernet with a Macbook worked.
    – cclloyd
    May 16, 2018 at 1:01

Please run the terminal command:

lspci -nn

Is your wireless device ID 14e4:4331? If so, please download this file and transfer it to your Ubuntu machine on a USB key or similar. Drop it on your desktop. Right-click it and select 'Extract Here.' Now back to the terminal and do:

sudo mkdir /lib/firmware/b43

The folder may already exist; that's fine, just proceed.

sudo cp Desktop/b43/*  /lib/firmware/b43
sudo modprobe -r b43 && sudo modprobe b43

Your wireless should now be working.


If this is not your device ID, please post it and we'll proceed.

  • @Chill555That is my device I.D. But when I ran your suggested commands but they didn't work this is what I got: alex@alex-Macmini:~$ sudo mkdir /lib/firmware/b43 [sudo] password for alex: alex@alex-Macmini:~$ sudo cp Desktop/b43/* cp: target Desktop/b43/ucode9.fw' is not a directory alex@alex-Macmini:~$ sudo cp Desktop/b43/* cp: target Desktop/b43/ucode9.fw' is not a directory alex@alex-Macmini:~$ /lib/firmware/b43 bash: /lib/firmware/b43: Is a directory alex@alex-Macmini:~$ sudo modprobe -r b43 && sudo modprobe b43 Jan 3, 2013 at 19:19
  • Sorry about the format I did press enter at the proper time. Jan 3, 2013 at 19:27
  • Your second command should be: sudo cp Desktop/b43/* /lib/firmware/b43. All in one command but with a space between the * and the following /. In human language, it means, as super user, copy everything in 'Desktop/b43' to '/lib/firmware/b43. It has to be in one command on one line. Please try again.
    – chili555
    Jan 3, 2013 at 21:58
  • I did everything correctly and nothing happened. So I filled the file map into the file system and found all the files had successfully copyed into the driver section but nothing is happening I performed a reboot as well and still nothing. Any ideas? Jan 5, 2013 at 1:49
  • Let's see if there are any clues here: dmesg | grep b43. Then a second command: rfkill list all. That funny pipe symbol | is on the right side of my US keyboard on the same key with \.
    – chili555
    Jan 5, 2013 at 1:59

Broadcom chips are not supported well with linux, if you need more information about why the Arch linux documentation provides a good inside (https://wiki.archlinux.org/index.php/Broadcom_wireless).

Lets get the wifi driver installed,

You need to make sure that repository sources are set to download and compile drivers from the source package itself, inorder to enable source code repositories refer to https://help.ubuntu.com/community/Repositories/Ubuntu#Adding_Ubuntu_Software_Repositories, usually in linux mint/ubuntu in “Software sources” application should have a option to enable “source code” option.

After enabling source packages open up a terminal and run following commands, in order to compile a package from the source, you need kernel headers and debian package developer tools.

sudo apt-get update
sudo apt-get install linux-headers-generic linux-headers-`uname -r`
sudo apt-get install dpkg-dev debhelper dh-modaliases
sudo apt-get install --reinstall bcmwl-kernel-source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.