I have Ubuntu 12.10 installed on an hp pavillion dv5 laptop I can't enable wireless networks. I am able to connect to wired networks though. I have a wireless button that's currently set on disabled, and when I try to enable it through the button, nothing happens! What do I need to do to enable my wireless network?

From lspci | grep 802, I got nothing. From lspci, I got the following relevant output:

08:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

From Software sources, it doesn't show any additional drivers.

From here, I use Atheros AR928X but I don't know where to put the blacklist stuff into.

  • What does lspci | grep 802 reveal? Is it activated in BIOS? – user unknown Jan 1 '13 at 20:03
  • mmmh... did you try to install drivers from additional drivers... check out this website, it might help link – mathematiker Jan 1 '13 at 23:08
  • What is the output of lsmod | grep ath? – qbi Jan 20 '13 at 0:31

Provided that the wireless adapter actually works (for example, can you try it under a Windows installation?), your options may be limited. I had a nearly identical experience with an HP Envy dv6 7200, and posted a number of potential solutions that I tried for enabling wireless (see How do I turn on wireless adapter on HP Envy dv6 7200 under Ubuntu (any version)?). After several days of futzing around with it, I finally returned it an bought a Dell Inspiron instead (works great with Ubuntu 12.04).

You might find it useful to step through the solutions I tried and see if any of them work for your model.

If your laptop is no longer under warranty, you can try messing with the actually wireless card itself (see Solution 3 in the above link, as well as the answer that follows). Apparently people do have success with this approach, but obviously it's more involved and possibly risky.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.