2

I have ubuntu 32 bit on an i7 processor. I tried to compile and install this package called xgrafix, I have installed dependencies, but now it has an error as follows.

samir@samir-HP:~/Downloads/xgrafix$ ./configure --with-X11_LIBDIR /usr/lib/i386-linux-gnu/
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: /usr/lib/i386-linux-gnu/
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... Invalid configuration `/usr/lib/i386-linux-gnu/': machine `/usr/lib/i386' not recognized
configure: error: /bin/bash ./config/config.sub /usr/lib/i386-linux-gnu/ failed

I have tried several things but was unable to resolve this.

  • That does not look like a good switch: "--with-X11_LIBDIR". Try using just `./configure' and see how it goes. – user8290 Jan 1 '13 at 18:11
  • it says libX11.a and libX11.so not found and ask to supply location with "--with-X11_LIBDIR". @Christopher – Samir Chauhan Jan 2 '13 at 5:52
3

Finally I am able to build it. what I probably missed is "=" sign after the switch that i have applied. so i changed it as bellow.

samir@samir-HP:~/Downloads/xgrafix$ ./configure --with-X11_LIBDIR=/usr/lib/i386-linux-gnu/

it worked. Thanks a lot.

  • I have compiled and build deb package (Compile binary) for XGRAFIX on ubuntu 12.04 64 bit, If any one need it Let me know. With this you can easily install and uninstall it, this package is used by XOOPIC plasma simulation tool and many other plasma tool by berkley university. Let me know if you need any of that binaries, I cant promise but I will try to provide. – Samir Chauhan Mar 28 '14 at 5:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.