How can I set the location for the login screen with lightdm in a multi monitor setup.

If have two monitors (1920x1080) + (1920x1200) and currently after I boot the login is shown on the left (smaller) monitor. I would like to view it only on the right (bigger) monitor.

Switching the cables on the graphics card did not help, and I have already made the bigger screen my primary screen using xrandr:

xrandr --output DVI-1 --primary #big screen

After login my panel is on the primary screen but the login screen itself is shown on the other smaller screen. How can I configure lightdm to display the login only on the bigger screen.

  • I have the exact same issue. Can't find the X11 configuration for LightDM
    – Ben Orozco
    May 22 '14 at 23:49

At least with Ubuntu 16.04, which includes lightdm-gtk-greeeter 2.0.1, the following entry in /etc/lightdm/lightdm-gtk-greeter.conf can be used to fix the initial position of the login dialog on a certain monitor:


The xrandr workaround didn't work here, too.

  • 3
    It's probably important to note that the monitor number 0 is the left most monitor and not whichever is set to "primary". For example, on my triple monitor system where my center monitor is set to "primary" with XRandR, it seems I need to set active-monitor to 1.
    – Octopus
    Jul 12 '17 at 17:00

This did the trick for me. Find out your primary screen:

$ xrandr

And create the file /usr/bin/dualmon.sh with the following command:

xrandr --output DVI-0 --primary

**Change DVI-0 for your primary screen.*

Make it executable:

sudo chmod +x /usr/bin/dualmon.sh.

And add it to /etc/lightdm/lightdm.conf file:



  • No need to create a script, simply write the command direct in to the config file.
    – coxe87b
    Apr 19 '20 at 2:03

Once you find out your screen identifier as Ben suggested using xrandr then you can pick your desired display output (mine was called HDMI-1) and enter it direct in to the config file.


Search for the line "display-setup-script" and change it to read:

display-setup-script=xrandr --output HDMI-1 --primary

Obviously replacing "HDMI-1" with your desired monitor, eg. "DVI-1" or "DP-1" for DVI or DisplayPort if not HDMI.

I currently use lightdm-webkit2-greeter so I don't have this option, but if you use the lightdm-gtk-greeter then you can do the following instead:


In the file /etc/lightdm/lightdm-gtk-greeter.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.