Chromium on Ubuntu 12.04. Youtube says:

This video is currently unavailable

I don't know why but this is the case for some videos, but not all. Well, most videos. And I don't know what's wrong.

Anyone help?

  • I'd guess youtube has the problem not Ubuntu, but however that's just a guess :P
    – Oyibo
    Jan 1, 2013 at 7:47
  • 1
    I have the same problem. It worked with both Firefox and Chrome (not Chromium). Flash in Chromium worked on other pages.
    – Jakob
    Aug 22, 2013 at 7:49
  • Chromium has the problem. The same thing does not happen with Chrome for the same search or websites. I've filed numerous feedback forms, but they only seem to fix the problem with that video, eg "Little Black Submarines".
    – jfa
    Mar 24, 2014 at 23:43

5 Answers 5


I'm using Chromium Version 28.0.1500.52 Ubuntu 12.10 (28.0.1500.52-0ubuntu1.12.10.3) and faced with same issue. To solve issue you need to remove current set of chromium codecs:

sudo apt-get remove chromium-codecs-ffmpeg

And them install similar, but extra package:

sudo apt-get install chromium-codecs-ffmpeg-extra

YouTube trouble will be removed and video will be played.

So, common solution leads to update chrome/chromium codecs.

You can also be faced with proposition to install chromium-codecs-ffmpeg-extra while removing chromium-codecs-ffmpeg. Just apply suggestion to install package with extra version.

Additionally, will be useful to update current version of chromium browser to take newest version:

sudo apt-get install chromium-browser


  • Had the same problem on Lubuntu 12.04. YouTube was giving player error 1. Followed above instructions and the problem was solved. Nov 18, 2013 at 20:45
  • 13
    You don't have to remove chromium-codecs-ffmpeg as it will ask you to remove chromium as well. If you install chromium-codecs-ffmpeg-extra the first package will be removed without uninstalling chromium. Nov 19, 2013 at 5:37
  • This worked for me, without forcing me to switch back to flash. :) Dec 11, 2013 at 11:16
  • 1
    @RémiBenoit, when you install the extra-package, it automatically removes the standard one because the chromium-codecs-ffmpeg-extra contains chromium-codecs-ffmpeg PLUS some additional codecs so it doesn't make sense to be able to keep both at the same time. But, yeah, Alexander's solution works really great. Jan 12, 2014 at 0:56
  • 1
    Thanks, but didn't forget to do this steps with Chromium closed. I do that learning this answer on Chromium and forget to close it - I had to force finish. Thanks! Feb 6, 2014 at 23:10

You can test to see if it's a problem with Chromium's built-in Flash player by joining YouTube's HTML5 trial, which will switch you over to YouTube's new HTML5 video player. If the videos work then, something is messed up with your installation of Chromium/Flash player. Try reinstalling it. If they still don't work, it may be a problem on YouTube's end or your ISP's end or somewhere in between. Could you comment with an example of a video that's giving you this error?

Also, does this appear to be a YouTube error, or an error that you're receiving from Flash/Chromium?

  • 3
    Oh, apparently, I'm already in the HTML5 trial. I left and I think that solves the problem. I'll come back later to confirm. Thanks in advance.
    – Guissmo
    Jan 1, 2013 at 7:10
  • 1
    You're certainly welcome! I don't know if you can mark my answer as the solution with the question closed, but I'd appreciate it if you can. Glad it worked! Jan 2, 2013 at 22:43
  • I had the same problem with Chromium only: YouTube videos on the other browsers on the same computer worked fine. I was in the HTML5 trial, I left it and it solved the problem. All videos works fine now. Jul 10, 2013 at 8:22
  • 2
    Alternatively, just install chromium-codecs-ffmpeg-extra package. No need to leave html5 trial, see answer by Alexander Borodulya below.
    – here
    Dec 29, 2013 at 22:06

Fix this problem by replacing the default, limited set of patent-free codecs, with the package containing all codecs. Run:

sudo apt-get install chromium-codecs-ffmpeg-extra

(Answer yes when asked if you want to remove chromium-codecs-ffmpeg and have chromium-codecs-ffmpeg-extra installed instead.)

After the install, you'll need to restart Chromium.

Why this happens

Chromium is (for political/ideological reasons) by default only installed with patent-free codecs (Ogg, Vorbis and Theora), which means that much video and audio content on the web will be in formats that Chromium does not understand.

The chromium-codecs-ffmpeg-extra package contains both the patent-free, and a bunch of (widely used) patented codecs.

Description of the chromium-codecs-ffmpeg-extra package:

This package contains the multi-threaded ffmpeg codecs needed for the HTML5 <audio> and <video> tags. In addition to the patent-free ogg, vorbis and theora codecs, aac / ac3 / mpeg4audio / h264 / mov / mp3 are also included. See chromium-codecs-ffmpeg if you prefer only the patent-free codecs

  • Thanks for the a solution and an explanation for why this issue occurs!
    – idbrii
    Mar 21, 2014 at 1:13

Same issue. In http://www.youtube.com/html5 player was set as flash. Problem was with cookies i deleted all browser cookies, than went to http://www.youtube.com/html5 enabled and disabled html5, than in new tab video started to work.


But switching to viewing through a proxy server usually fixes the problem, it seems to be something to do with the region definition for the browser as Firefox seems to work unaided.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .