47

I have remote box accessed by VNC and jwm desktop.
No menus, not desktop icons, only a terminal window.

I have downloaded Chrome's .deb package and installed it.

How can I run it from the terminal window?

88

Well simply typing google-chrome works fine for me. It might not work if you installed Chromium. chromium-browser is for Chromium.

  • For Chrome:

    google-chrome
    
  • For Chromium:

    chromium-browser
    

However if it's a remote box... At least via ssh you must use -X when option connecting to be able to run windowed apps. Like this:

ssh -X username@server.lt
  • 1
    google-chrome-stable may also be the command. – Dodgie Mar 7 '16 at 6:35
15

If you get the path where the application is installed then you can run the application from there

For example to know the path where google-chrome is located run this command:

whereis google-chrome

You will get the path like:

google-chrome: /usr/bin/google-chrome /usr/bin/X11/google-chrome /usr/share/man/man1/google-chrome.1

Now you can run chrome by either executing two commands:

/usr/bin/google-chrome
/usr/bin/X11/google-chrome

Note: it will be applied for all installed applications. Also, It would be possible that you would not get the path /usr/bin/X11 or would get something different.

Hope you like this way to find the path and run chrome :)

3

In Ubuntu 15.10 this command works very well

google-chrome www.google.com

for more options you can use

google-chrome --help
2

Enter to opengoogle-chrome, and exit google-chrome to close the Chrome browser

1

Type

google-chrome-stable

I use this command and it works for me. I too installed it using the .deb package. So this should work for you too. Typing an url after the command opens the url.

0

We can also use following command:

gnome-www-browser
-1
/opt/google/chrome/google-chrome
  • Please make your answer more complete as only the code is not accepted here. – Star OS Jan 1 '16 at 9:13
-2

If it is Ubuntu 15.10, and you downoaded it from the chrome webpage, then instaled it with command line, then it should be:

chrome google-chrome
  • 1
    Most likely this is incorrect, from what i think. – Star OS Jan 1 '16 at 9:42
  • Please tell the answer after you have confirmed that it's working.:) – john400 Jan 28 '18 at 17:07
-2

simply type "chromium-browser" in your terminal.This is sure to work in elementary OS which is distribution of Ubuntu;so do in Ubuntu itself

  • 2
    That won't work for Google Chrome, which is what the original question references. – xiota Jun 7 '18 at 18:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.