I was just copying audio files into my 2GB USB mp3 player, then i had a problem saying that it could not copy files into the drive any more, i tried removing it and trying again, but it didn't work, but the files already copied to the drive where working just fine and i was able to read them.

But after the problem remaining i decided to format the drive using Disks, but somehow this didn't work. When i choose to format the drive nothing happens and I get no error messages. So i tried Gparted and it worked, I formatted the drive as FAT32 but after this, the drive doesn't show up, in Ubuntu, Disks, Windows or even GParted. The drive is still working because its a mp3 reader, and when i try to use it just says that there are no files in it (because of formatting it of course).

There is any way I can restore my flash drive back? Any ideas will be very welcome :)


It's possible your USB connector or cable is damaged, and preventing the computer from recognizing the flash drive/mp3 device. Plug the drive in under Ubuntu and run the command LSUSB in a terminal. If the flash drive doesn't show up, try another port or cable. If it does, then try and format it again. check and see what file system your computer is formatted as again and make sure you use the same one on the flash drive. One other comment. Some MP3 Players come with a small file (frequently less than 100kb) pre-installed, that contains vital information for the proper function of the device. If yours had one, and you deleted it, then you might be stuck.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.