2

The audio configuration must have changed from 9.10 to 10.04, because audio no longer seems to work with DOOM 3. This was the suggested way to run DOOM 3 before, and it worked fine:

doom3 +set s_alsa_pcm plughw:0

However, DOOM 3 is completely silent after I upgraded to Ubuntu 10.04. Has anyone gotten the audio for DOOM 3 to work in Lucid Lynx?

Edit: Here's some potentially useful console output:

------------------------------------
dlopen(libasound.so.2)
asoundlib version: 1.0.22
Alsa is available
------ Alsa Sound Initialization -----
snd_pcm_open SND_PCM_STREAM_PLAYBACK 'plughw:0' failed: Device or resource busy
dlclose
WARNING: sound subsystem disabled

Edit2: Well, it seems that DOOM 3 is unable to share, like other applications, so closing Rhythmbox and Chrome and anything else that shows up in Sound Preferences under the Applications tab worked. I would like to get it to play nice like everything else, but that may be too much to ask. If someone can come up with a solution that causes DOOM 3 to coexists peacefully with other applications would constitute an accepted answer. It sucks to have to close everything else first.

1
  • Sadly Doom III stopped working for me after upgrading to 10.04 :/
    – invert
    Aug 16, 2010 at 9:00

4 Answers 4

2

Try change the driver to OSS, perhaps like this (sorry I can't verify this command atm):

doom3 +set s_driver oss

Also check that nothing else is using the sound card, like a music player?

2

Have a look here: PulseAudio - Perfect Setup #Quake3

1

Try installing the libsdl1.2debian-alsa package.

1

To get sound working in quake4 (same engine as doom3), I had to combine the 2 suggestions above:

sudo apt-get install libsdl1.2debian-alsa

doom3 +set s_driver oss

Not the answer you're looking for? Browse other questions tagged .