After running Update Manager, a debconf window (titled "Configuring grub-pc"), popped up, requiring me to select the appropriateGRUB install devices for my system. I've made no changes to grub or the filesystem recently, and I don't remember what options I selected last time I did make a change.

How do I know what to select? I'm assuming the wrong answer could render my system unable to boot.

Here's the debconf dialog:

Debconf window, configuring grub-pc, containing check-boxes for /dev/sda and /dev/sda1

Here's the window and text that is displayed when selecting "help" :

Grub was previously installed to a disk that is no longer present

  • 8
    This dialog also crops up when upgrading a virtualbox vm's ubuntu version (in my case, 10.10 -> 11.04). – Noel Jun 7 '11 at 13:33
  • 2
    As far as my experience with this, it looks like a usability bug. I have run updates countless times and whenever this dialog pops up, I click nothing in the first dialog and then confirm that I want to continue without installing grub. Never had a problem so far. I guess it is because grub is already installed in the proper MBR otherwise the machine would not have booted in the first place. – Coffee_fan Mar 22 '15 at 18:48
  • 2
    wtf is that ? I just wanted to update a few package as it was suggesting, now I need to make a choice that might kill my system... such bad bad bad stuff !! – nicolas Mar 3 '16 at 8:24
  • 2
    This is a terrifying experience! I just had it while simply doing an apt upgrade on Ubuntu 16.04.3 LTS (running inside a VirtualBox VM on a Windows 10 host which just got restarted due to updates, I thought it messed everything up) -- nevertheless it worked after choosing /dev/sda – Daniel F Nov 6 '17 at 22:52
up vote 58 down vote accepted

In your case, the correct selection is /dev/sda, the first one. It's the first and only hard disk in your system, whereas /dev/sda1 is a partition on that hard disk. You can install grub on a partition, but it's a "BAD idea".

If you had multiple hard drives and partitions, first find out where your root partition is:

lsblk

(See also: How do I find out what hard disks are in the system?)

You can then install grub on that hard drive. Look for devices labeled "disk" (e.g. "sda", meaning /dev/sda) to install grub into the master boot record (every physical disk device has only one MBR, no matter the partitions).

  • 15
    To finish off the story (which has ended well enough): I selected /dev/sda as suggested. On the next window, I was asked if I wanted to continue without installing grub. Odd, of course, since I had just asked to install it. There was a checkbox to mark to continue without installing, or, if I pressed the "Forward" button, it went back to the previous screen, asking where I wanted to install grub. Instead of looping forever, I checked the box, told it not to install grub and crossed my fingers. On reboot, there were no problems. It remains perplexing why this interaction was required. – belacqua Jan 27 '11 at 6:01
  • 2
    @StefanoPalazzo So what causes the install/don't install loop? I just had the same experience in 12.04. – Wes Miller Dec 30 '13 at 13:55
  • 2
    I just had the same issue on 14.04. I would say this was a bug, if not in code then in usability. – sevis127 Oct 14 '14 at 1:18
  • 2
    Just got the same thing on 14.04. I think the purpose of the dialog was to ask you whether you would like to install Grub on any other drive, other than the one it is currently installed on, and thus showed you the "Continue without install" option. I am not totally sure about this, though. – Mo2 May 16 '15 at 2:54
  • 1
    When I install a computer with LVM, it puts partitions on things that df shows as /dev/mapper/<name> where <name> is the label for that device. For example, I created a VPS with VirtualBox and my root partition is on /dev/mapper/snap--vg-root. – Alexis Wilke Aug 6 '16 at 22:50

This issue was still present when I upgraded Ubuntu 16.04 after a fresh install. To fix it, do this:

  • The selection of /dev/sda is correct, so press Spacebar for the first option.
  • An asterisk appears for the /dev/sda option, signifying successful selection.
  • Then press Tab key to highlight the 'OK' button and then press Spacebar key to select the OK action.

After this, the installation should proceed smoothly.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.