I'm running 12.10 dual booted with windows 7 (nvidia optimus). I have no idea what might be wrong because:

  1. the monitor works on windows
  2. it worked on ubuntu for over a year and even now the splash screen shows up on the external monitor while ubuntu is booting
  3. the monitor is detected and shows up in the workspace switcher
  4. I connected it to another monitor through hdmi and it works fine
  5. it works fine through VGA (but for some reason it's not as sharp)
  6. changing the resolution didn't help
  7. changing cables didn't help

here's my xrandr output:

Screen 0: minimum 320 x 200, current 3286 x 1080, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 293mm x 164mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+1366+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080      60.0*+   50.0     60.0     25.0     30.0  
   1600x1200      60.0  
   1680x1050      59.9  
   1680x945       60.0  
   1400x1050      74.9     59.9  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       75.0     59.9  
   1280x960       60.0  
   1366x768       59.8  
   1360x768       60.0  
   1280x800       74.9     59.9  
   1152x864       75.0  
   1280x768       74.9     60.0  
   1280x720       50.0     60.0  
   1024x768       75.1     70.1     60.0  
   1024x576       60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   720x576        50.0  
   848x480        60.0  
   720x480        59.9  
   640x480        72.8     75.0     66.7     60.0     59.9  
   720x400        70.1  
DP1 disconnected (normal left inverted right x axis y axis)
  • I have the same problem. I don't if it helps but for me the problem started occurring this morning (after 10 months without any issues) as I boot up my laptop. Maybe an update which I installed yesterday evening broke something
    – Max
    Feb 20, 2013 at 15:11
  • I have the same issue as of 10/22/2013 with Ubuntu 12.04 LTS and Intel HD integrated graphics. I've found that it works as expected in "Ubuntu 2D" desktop mode.
    – Jordan P
    Oct 22, 2013 at 15:42

6 Answers 6


I had the exact same problem as the question poster: Ubuntu 12.10, Nvidia card, monitor connected via HDMI, using nouveau driver, monitor worked before (with the same setup), the monitor is detected and enabled in Ubuntu, but no signal to monitor.

The temporary solution: I'm running Ubuntu on a laptop and there is a special key on my keyboard which allows me to enable/disable external displays (in my case the key is Fn + F7, this differs per laptop). So I just pressed that key combination and the external monitor immediately was turned on.


Though the key combination to enable the external monitor works, you'll have to repeat this every time you reboot. I found a way to have the external monitor automatically detected and enabled at the login screen (after a reboot). And when you login, the previous settings for your monitors are restored, as you would expect. Here's how to do it:

Note: I only tested this with an Nvidia card. And before you continue, I recommend you install SSH first (sudo apt-get install ssh) to be safe. In the case something goes wrong and both internal and external monitor stop working, you can always undo whatever you did by logging in from another computer via SSH (e.g. ssh user@ So make sure you know the IP address of your computer in the network.

  1. First of all, run sudo apt-get install v86d in a terminal to install the v86d package.

  2. Run gksu gedit /etc/initramfs-tools/modules or sudo vim /etc/initramfs-tools/modules and add the following line at the end of the file (replace 1280x1024 by the resolution of your internal monitor):

    uvesafb mode_option=1280x1024-24 mtrr=3 scroll=ywrap

    save and exit.

  3. Create the file /etc/initramfs-tools/conf.d/splash by running gksu gedit /etc/initramfs-tools/conf.d/splash or sudo vim /etc/initramfs-tools/conf.d/splash with the following content:


    save and exit

  4. Now you need to update the initramfs image because we changed some configurations. Do this by runnning sudo update-initramfs -u.

Now reboot your system and your external monitor should get a signal as soon as the Ubuntu login screen appears.


I used nvidia-settings command to enable external monitor (selected TwinView mode). Note native "Gnome Classic" Displays configuration dialog did not detect external monitor. This was on Ubuntu 12.04.



I had a similar problem on an Ubuntu 12.04 desktop with an Geforce GT 640 (Baby Kepler version) and the nVidia 310 drivers. When disconnecting and reconnecting a second monitor, in all trials expect one, the monitor seemed to be working properly: correct EDID, detecting monitors works properly, mouse moves off screen to other monitor's area, nvidia-settings reports proper info for both monitors.

However, the monitor reports 'no signal', displays no image, and otherwise acts as if it was stuck in dpms suspend mode. Disconnecting the monitor also worked as expected, and the system would reconfigure for single monitor mode.


sudo vbetool dpms on

resolved the issue. Of course if you don't have vbetool installed, you'll need to run:

sudo apt-get install vbetool

to install it. I suspect in my case a reboot or logging in and out would have also fixed my issue, but since it was resolved by the above command I didn't get to test that thoery (nor do I really want to, of course). note that various actions in nvidia-settings (such as changing resolution, enabling/disabling various monitors, and so on) had no effect.

  • This worked, but also resulted in a complete screen lockup (with Nvidia drivers). I ended up having to reboot anyway. May 30, 2014 at 16:16

9 years after... I'm using Ubuntu 20.04 I'm getting the same behavior with an Mesa Intel® UHD Graphics (CML GT2).

Used the temporary workaround Fn + F7

  • 1
    This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. - From Review
    – David
    Apr 12 at 12:03
  • @David though it's not a direct answer to the question, it is important to refer this behavior still exists in a new version of Ubuntu. Should I duplicate the same question and only differ in Ubuntu version?
    – mseromenho
    Jun 2 at 14:02

I recently had trouble with my Optimus-enabled laptop running the binary Nvidia drivers. To rule out whether the Nvidia drivers are the problem, try removing them:

sudo apt-get purge nvidia*

Then make sure your system has the open-source version:

sudo apt-get install xserver-xorg-video-nouveau

Then restart, and your laptop will be running the nouveau open-source drivers. If your monitor works after that, you know the binary drivers are suspect; because you said it has been working, a recent update may have broken the multi-display functionality.

  • I have the same problem (and the monitor worked before). I tried your solution, but no effect (besides, I was already using the nouveau driver). Jan 8, 2013 at 19:57

I was facing the same problem with an external monitor connected to my laptop's USB-c port using HDMI to USB-c adapter/dock. Nothing else worked so finally I just decided to swap the USB-c port. Weirdly enough that did the trick and now everything is working again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.