I use Linux at work and am pretty happy setting up and installing to new machines in several configurations, however I have to admit, this time I'm stumped!

I have a nice new PC with an SSD Raid in place. It currently has windows 7 installed, and I was able to successfully install ubuntu (12.04) from a live usb. When I reached the end I had the error

executing grub-install failed 

I finished the install without installing GRUB expecting to be able to do this seperately after, I did some googling and came across the following advice:

Create a temp folder, and link to the linux partition. Run the following command "sudo grub-install --root-directory=/home/ubuntu/Temp /dev/mapper/[PARTITION HERE]"

in my case:

sudo grub-install --root-directory=/home/ubuntu/Temp /dev/mapper/pdc_ifegdfjd5

I get the following error:

/usr/sbin/grub-probe: error: unknown filesystem.

Auto-detection of a filesystem of /dev/mapper/pdc_ifegdfjd5 failed.
Try with --recheck.
If the problem persists please report this together with the output of "/usr/sbin   /grub-probe --device-map="/home/ubuntu/Temp/boot/grub/device.map" --target=fs -v  /home/ubuntu/Temp/boot/grub" to <bug-grub@gnu.org>

So I've run with --recheck and get the exact same error.

I'm not entire sure where to go from here, I've some more googling, but not getting any positive result.

The output of fdisk -l:

Device Boot      Start         End      Blocks   Id  System
/dev/mapper/pdc_ifegdfjd1   *        2048      206847      102400    7  HPFS/NTFS   /exFAT
/dev/mapper/pdc_ifegdfjd2          206848   184526847    92160000    7  HPFS/NTFS/exFAT
/dev/mapper/pdc_ifegdfjd3       184527102   464843519   140158209    5  Extended
Partition 3 does not start on physical sector boundary.
/dev/mapper/pdc_ifegdfjd5       184527104   431427327   123450112   83  Linux
/dev/mapper/pdc_ifegdfjd6       431427584   464843519    16707968   82  Linux swap / Solaris

Can anyone point me in the correct direction?

Many thanks,




(updated from earlier answer)

I booted to a live cd (well USB) and followed these instructions to get boot repair running:


After this I ran boot repair and simply used the automatic option. When it eventually got to installing grub (in a dos type windows) I selected the first windows 7 area to install it on (I think!)

After reboot things were ok and grub was booting.

  • nb: the system I am talking about in the guide is another one I have and I am not trying to boot from the raid drive on it (just in case you are confused by me seemingly having this fixed ;) – tentimes Jan 2 '13 at 22:13
  • Hi Tentimes, Thanks for the response, it looks like a method I've not tried - I'm no longer in front of the system, as it was a friends system I was trying to convert to ubuntu - he's now 100 miles away, so I'll send the advice on, and see what we get back. Thanks again. – changeableface Jan 3 '13 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.