Disclaimer: I also posted this question at LinuxQuestions.org. I have Mint 14 (based on Ubuntu 12.10) installed right now, but this problem exists with stock Ubuntu 12.10 as well. If you insist, I can install straight Ubuntu 12.10 for the purposes of troubleshooting.

I have an HT Omega eClaro sound card based on the C-Media CMI8788 which is supported under ALSA with the snd-oxygen module. The card is not loaded by ALSA as a sound device either at boot time or by modprobing.

Relevant output of lspci

04:00.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]

Output of cat /proc/asound/cards

0 [NVidia         ]: HDA-Intel - HDA NVidia
                     HDA NVidia at 0xf6080000 irq 17
1 [Q9000          ]: USB-Audio - QuickCam Pro 9000
                     Logitech, Inc. QuickCam Pro 9000 at usb-0000:00:1a.0-1.3.1, high speed

The snd-oxygen module is not loaded at boot (not listed under lsmod). After I run sudo modprobe snd-oxygen the module loads but the device is still not accessible to alsamixer.

snd_oxygen             20948  0 
snd_oxygen_lib         41273  1 snd_oxygen
snd_mpu401_uart        14169  1 snd_oxygen_lib

Some possibly relevant websites:

  1. Crunchbang: [Solved] soundcard eclaro not working
  2. Ask Ubuntu: In need of driver for C-Media CMI8788 - I really don't want to rip out alsa
  3. Ask Ubuntu: How can I enable my Asus Xonar DGX (CMI8788 chipset) sound card?
  • 1
    The eClaro model is not supported by the snd-oxygen driver. You have to wait until somebody finds the time to write the code to handle that particular combination of AK4396 and CS4362 DAC chips.
    – CL.
    Dec 30, 2012 at 9:10


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.