12

Whenever I type a command which is similar to sudo apt-get install or anything like this I get this kind of error:

$ sudo su
# exit
exit
rm: cannot remove `/run/user/root/gvfs': Is a directory

How can I resolve it?

4
  • Please, could you paste the whole output and possibly the command that produces the error? Thanks! Dec 28, 2012 at 16:12
  • A very simple command,: kbkb@Abood:~$ sudo su root@Abood:/home/kbkb# exit exit rm: cannot remove `/run/user/root/gvfs': Is a directory. I'm sorry because i don't know how paste it like a code here Dec 28, 2012 at 16:16
  • GVFS is the GNOME Virtual File System. Does it help to unmount gvfs? Use gvfs-mount -l or gvfs-mount -li to get a list of mounted resources and gvfs-mount -u URI to unmount a given resource, where URI is the mounted resource.
    – user8290
    Dec 28, 2012 at 16:40
  • I don't actually know where this problem comes from, i don't know what do i have to do, i need a help please. Dec 28, 2012 at 16:45

1 Answer 1

11

Open your terminal (Ctrl+Alt+T) and run this:

sudo umount /run/user/root/gvfs
2
  • 2
    I ran umount /run/user/root/gvfs and it worked thanks. Dec 28, 2012 at 16:50
  • If you are already a root already, you can run this command without sudo umount /run/user/root/gvfs. Jul 25, 2013 at 6:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .