5

When I attempt to view a video file, I get a solid green screen with audio, regardless of the application or file format. This happens with .mp4, .gp, and .dv files.

I am unable to use live web cam with Skype, also getting a solid green screen. I am using 32-bit Ubuntu 12.04 on an iMac.

There is no problem viewing videos on the Internet, i.e. YouTube, etc., and the files I upload to YouTube play normally. I only have problems viewing local files. I do not use VLC Media Player. How do I go about changing the hardware acceleration?

5

While the root of the problem is likely hidden in your video drivers, a quick fix is to just disable hardware acceleration in Flash. You might experience a slight decrease in performance, but you'll actually get video working again without going to too much trouble.

In VLC Media Player:

  1. Click on Tools --> Preferences

  2. Click on the Video tab

  3. Uncheck the "Accelerated video output (Ovelay) box.

  4. Save these settings and it should work immediately.

For Youtube videos you could do this:

1) Right click on youtube video.

2) Go to settings.

3) UNCHECK the 'Enable hardware acceleration' tickbox.

4) Refeshed and works fine now.

I also recommend you to install/reinstall your video/display driver.

1

I have tried Mukund's answer and same other answers and its working, but i am just extending the answer that below follow is worked for me.

  1. Go to Tools → Preferences.
  2. Select Input/Codes → Hardware-accelerated decoding. In this, select the Disable option.

After restart the VLC and its should work. I hope this will help someone.

0

For me the above answer didn't work, but as I figured out, in my case the problem with green blinking of the screen were caused by enabled transparency (I am using a tiling WM with Compton which enables transparency for inactive windows).

So I could disable it. The other solution, that I gone with, is running VLC in a separate XServer, like xinit /usr/bin/vlc ./MyVideo.mkv -- :1 vt8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.