17

Recently I noticed all the new windows are popping up in the top left. This is annoying because the top bar blocks the title bar of the new window. See screenshot of Tunesviewer with Firefox, Tunesviewer can't be moved without alt-drag trick.

enter image description here

16

Yeah by-default Ubuntu opens it in the top-left corner of the desktop. You can open it in the centre by doing the following:

  1. Install CompizConfig Settings Manager from the Ubuntu Software center if the application is not in your system. You could also install it from the terminal by typing:

    sudo apt-get install compiz compizconfig-settings-manager compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-plugins
    
  2. Press Alt+F2 and type ccsm into the box, press Enter to run this program. (You may receive a warning to use this advanced tool with care.)

  3. Select "Windows Management" from the left panel.

  4. Click "Place Windows".

  5. Change Placement Mode from "Smart" to "Centered", click "Back" and "Close".

Ideally, the window manager in Ubuntu should restore the last known position of an application window, but it does not do that unless an application remembers its own window position. (See reported bugs)

  • 6
    That is not default, I had unchecked it in compizconfig. Thanks :) – NoBugs Dec 27 '12 at 6:26
  • 3
    Don't forget to enable "Place Windows" – Behnam Abaie Nov 21 '16 at 19:01
  • 1
    Does not work now, some packages are not found. :( – Faheem Nov 22 '18 at 15:28
  • @Faheem , how about you try this solution: askubuntu.com/a/858960/309223 – geras May 14 at 10:20
  • 1
    Thanks, @geras. I used the same solution to fix the issue, 6 months ago. :P – Faheem May 14 at 16:20

protected by Community Apr 1 '17 at 20:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.