I'm trying to make a bootable installation USB drive. I've tried usb-creator-gtk, and it starts working only to fail with a segmentation fault, leaving a non-bootable drive. I've tried "unetbootin", and it makes a bootable drive that cannot even begin an installation successfully. (I can't tell what it's problem is, but the result is utterly unworkable; the installation process just hangs.)

This seems like something that should be pretty simple, and pretty easy. What am I doing wrong?

My 12.10 installation from which I'm trying to run usb-creator-gtk is up-to-date, and other than this it works fine. The USB stick is fine (and I've tried this with several different USB sticks with the same result).

  • Have you checked the md5 of the iso to make sure it's valid? – tr33hous Dec 26 '12 at 1:13
  • While usb-creator-gtk (0.2.40ubuntu1) works fine here in 12.10 there are some still reporting issues such as yours. As far as unetbootin, - try formating the usb drive 1st in disks or gparted to FAT32 before using unetbootin – doug Dec 26 '12 at 4:32
  • 1
    I worked around the issue by burning a 12.10 DVD. I tried all sorts of workarounds, and my conclusion is that the tools are simply broken. – Pointy Dec 26 '12 at 4:43
  • @doug the drive was freshly formatted. The unetbootin tool was completely unworkable; every step of the way reported an error. – Pointy Dec 26 '12 at 4:44

I have successfully created a new USB boot drive using the following command:

$ sudo usb-creator-gtk --allow-system-internal

WATCH OUT! This may list additional drives in the target list. Be super careful not to overwrite your system partition.

According to this Ubuntu bug report, this is a very common issue. The comment that lead me to a solution is here.


Install unetbootin from Ubuntu Software Centre. It will help you create any Linux bootable USB stick

  • 1
    Thanks, but as the question noted that was one of the things I tried. I don't recall the details but it absolutely failed. Thanks though! – Pointy May 8 '13 at 14:36
  • Sorry, I think I missed the part. i would suggest, try to install the unetbootin from the repos and use a freshly downloaded .iso. To be honest, this has never failed me. I have always been able to get a working live usb with unetbootin. – Ubuntuser May 8 '13 at 14:44

It seems to be a new bug in 13.10 which will fail to create a USB disk from a file located in a folder with accent (for exemple in french "Téléchargement" which is the download directory).

So copy that file in another place and retry to create the USB disk.

The source here.


I had the same problem, usb-creator-gtk was segfaulting, but I found another answer that said to use dd:

sudo dd if=/path/to.iso of=/dev/sdd

This worked the first time! This can be dangerous if you are unsure which device is your USB stick, use gparted or other tool to be 100% confident.


This is a slightly lame option, but it's the one I reverted to just now (didn't find this post in time).

Switch to good ol' reliable Windows! Yay. If you have machine running Windows somewhere, you can download the "Unversal USB installer" as per the official Ubuntu install guide:


It's just a matter of downloading the installer executable (currently from here, see link in docs above if it's changed), running it, choosing a source ISO and target drive, and then waiting...

Screenshot of windows USB installation

Does it seem wrong to resort to using Windows to install Ubuntu? Who cares! It works!

P.S. - it does take absolutely ages though. And, as per the screenshot, the progress bar is no help. You'll need patience!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.