After a recent upgrade my boot options were changed.

Following instructions I found, I downloaded a tool called grub-cfg and used it to change my boot options. Unfortunately, it didn't work.

The options from my configuration in /boot/grub/grub.cfg and the boot options that are actually shown are different. Here are my grub.cfg headers (my full grub.cfg is here):

menuentry "Ubuntu" --class ubuntu --class gnu-linux --class ...
menuentry "Ubuntu, with Linux 12.04 3.2.0-24-generic" --class ubuntu ...
menuentry "Memory test (memtest86+)"
menuentry "Memory test (memtest86+, serial console 115200)" 
menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows ...
menuentry "Windows Recovery Environment (loader) (on /dev/sda3)" --...

The boot menu actually looks like:

Options shown are different from the menuentries in grub.cfg!

If I understand things right, the entries from the grep are exactly what I should be seeing on the boot screen, but they obviously aren't. I want the grub boot options to be what I set them to with grub config; the default should take me to the 12.10 kernel instead of the 12.04 (2.6.38-16 generic) kernel. What's going on?

Here is a bit more information. I was looking at /var/log/system.1 and found the following

Dec 26 14:23:20 hikari 40grub2: Skipping entry 'Ubuntu, with Linux 3.2.0-23-generic (on /dev/sdb6)':
Dec 26 14:23:20 hikari 40grub2: appears to be an automatic reference taken from another menu.lst
... Dec 26 14:23:20 hikari 40grub2: debug: parsing: ### END /etc/grub.d/41_custom ###

What's particularly interesting here is that on my system I have windows 7, Ubuntu 12.04 and Ubuntu 12.10. The grub.d/41_custom file lives on the 12.04 system not the 12.10.

So what happened is that after the last upgrade grub is reading 12.10 /boot/grub.cfg but parsing the /etc/grub.d from the 12.04 area.

Does anyone have suggestions where to look next?

How can this be?


1 Answer 1


After considering the discovery that reboot used a different partion for the /etc/grub.d files than the current OS version, I decided it must be using grub from the older install. I looked at the grub configuration graphical tool and discovered an option to re-install the MBR and did this. Problem solved -- I now boot from the proper grub.cfg file.

Thanks for the assistance. The suggestion about grub.d by WindowsEscapest is what put me on the right track.

Steve S.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .