Problem with this file /tmp-air-nkhvxz-setup-error-while-loading-shared-libraries-libgtk-x11-2-0-so-0

I try to solve this problem and try to install libgtk-x11-2.0.so.0

sudo apt-get install libgtk2.0-0:i386

sudo apt-get install ia32-libs

but two links above do not work. Is there any other alternative one?

closed as unclear what you're asking by Braiam, user.dz, belacqua, psusi, Avinash Raj May 6 '14 at 4:22

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.


I have the same problem and I was unable to fund solution on the internet, nothing worked for me. Finally I've managed it to work simply by installing libgtk2.0-0:i386 graphic library from the Ubuntu Software Center.

You can also type the following command in a terminal:

sudo apt-get install libgtk2.0-0:i386
  • For beginners like myself, I suggest using Software Center, because there you can actually see that two types of libraries exists, "normal" and i386 :) – Elvedin Hamzagic Mar 19 '14 at 11:57
  • Thanks for this, after doing this I was able to load Second Life / Opensim for a client of mine who requires educational tools. in the VR world. Really helped. Cheers – Paul Preibisch Jul 5 '14 at 10:09

To fix this issue. You must install ia32-libs-gtk, which is a virtual package of ia32-libs. Also try installing libglib2.0-dev

sudo apt-get install ia32-libs libglib2.0-dev

If the above did not work then try installing

sudo apt-get install libgtk2.0-0

The shared library you mentioned belongs to libgtk2.0.0. So the above command should solve the issue.

If you are running 64 bit Ubuntu, try

sudo apt-get install libgtk2.0-0:i386

This worked in 14.04 LTS

  • 2
    It's not working for me. – devo Oct 28 '13 at 3:15

You need to install some libraries:

sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386

Not the answer you're looking for? Browse other questions tagged or ask your own question.